0

I have a M1 Mac Mini running Big Sur (11.5.2). Had it for 30 days or so and have been accessing the internet via Ethernet since day one without problems - until a couple of days ago. After waking the computer from sleeping suddenly I wasn’t able to access the internet anymore (for the most part - read below). I switched to WiFi and it started working again. Thought it may be the cable so I tried a different cable to no avail. Tried the original cable with my MBP (via Thunderbolt 2 dongle) and that worked fine as well. I power cycled my router, which did not help. So it’s not the cable, switch or router.

Turned off WiFi and plugged the Ethernet cable back in and turned on VPN (ExpressVPN). Internet works! So WiFi and Ethernet on VPN work fine, but Ethernet on it’s own doesn’t.

Back to the problem itself which is strange. On a handful of sites, the internet does work on Ethernet. Best Buy, DuckDuckGo (gets search results, but can’t navigate to any of the links), Pocket, Reddit, Goodreads, Amazon (partially loads - probably from cache) seem to work okay (the pages load up but the browser tab icon keeps "spinning" for a while). But most other sites just don’t work - Google Sites, Yahoo, Wikipedia, Weather.com, etc. The error specifically is "Connection Timed Out"

The problem is not isolated to browsing. I opened Spotify and the Apple Podcasts app and they couldn’t connect to the internet either when using plain Ethernet. That said, say I use WiFi to start Spotify and go to a playlist (which works) and then switch to plain Ethernet and click play on a song - it works. If I then try and navigate to another playlist, then it just keeps spinning and times out.

Pinging sites on plain Ethernet works fine. Running traceroute seems to either take a while or timeout on most sites (even ones that work using the browser). This behavior is the same when I'm on WiFi so I'm not sure what that means.

I tried a few other things individually that didn’t help:

  • Created a new user
  • Started the Mac in Safe Mode
  • Did a fresh reinstall of MacOS
  • Via Network Preferences, Renewed the DHCP Lease
  • Via Network Preferences, Removed and re-added the Ethernet adapter
  • Via Network Preferences, Created a new Location (instead of "Automatic") and tried the Ethernet adapter
  • Connected Ethernet to the computer via a USB-C dongle to the Thunderbolt Port
  • Changed the default DNS to Google's DNS servers (8.8.8.8)
  • Uninstalled ExpressVPN

Does anyone know what might be the problem here?

(Edited to add other things I tried) (Edit 2: More specifics added regarding problem)

7
  • have you tried removing and re-adding the Ethernet adapter in the Network Preferences pane? It sounds like it may be a DNS issue, or something damaged in a setting. That would reset your E\ethernet network settings to defaults. Sep 6, 2021 at 19:12
  • @SteveChambers Yes I did to no avail. I've updated my question with everything I tried. Thanks.
    – Rick
    Sep 6, 2021 at 19:48
  • Could you provide us the make of your Internet router?
    – dan
    Sep 6, 2021 at 20:51
  • 1
    My prime suspect would be the VPN software not "letting go" properly.
    – Tetsujin
    Sep 7, 2021 at 8:13
  • I suggest you to turn off ExpressVPN, then uninstall it completely, then switch to your location with Ethernet only ( avoid the Automatic gadget when debugging ), then report.
    – dan
    Sep 7, 2021 at 12:12

1 Answer 1

1

After a number of calls with Apple Support, it turns out that the problem isn't related to my Mac. Discovered that the problem lies with either with my router or ISP with regard to resolving IPv6 addresses. WiFi (and I assume VPN) uses IPv4 to connect. When I updated my IPv6 setting to "Link-local Only" (forcing the use of IPv4 for external addresses) it works perfectly over plain Ethernet. Not sure what the downside is of using IPv4 exclusively but so far has not made a difference. Next call to my local ISP support to see what's going on.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .