2

I'm struggling with this since some months. I don't know if it is a third-party software I installed (been trying to debug with ps aux + lsof on /Library/Preferences/SystemConfiguration/preferences.plist/ but no luck finding out), but I'm completely unable to change any Wi-Fi settings, from the System Preferences GUI or the terminal using networksetup. The problem summary/behaviour is as follows:

  1. Can't disable Wi-Fi (it gets re-enabled straight away)
  2. Can't change any configuration (create/delete/change new locations, IP, DNS, etc...) they get reverted as soon as I click "Apply". Interestingly, the "recovery point" (the configuration it is reverted to) is not the default one, as for example I have a location created named "wyndham" that I cannot delete. The DNS get back always to 8.8.8.8.
  3. Same behaviour in the terminal with networksetup, e.g.
# sudo networksetup -setdnsservers Wi-Fi 192.168.1.100
Password:
** Error: Unable to commit changes to network database.
  1. I tried deleting files in /Library/Preferences/SystemConfiguration/ and interestingly, the only file that can't be changed is preferences.plist, which is the file that has this stuck, frozen network config.

  2. I tried rebooting to recovery mode, doing csrutil disable, reboot and tried to delete preferences.plist but it says "operation not permitted", even in recovery mode with csrutil disabled, and in normal mode happens the same. After trying that I enabled csrutil again, because it wasn't making any difference.

I had ExpressVPN software installed before, I removed it, removed all suspicious services and processes running, and tried to see if there's any process monitoring preferences.plist but no luck, tried using some logging techniques I found for debugging misterious DNS changes, but again, no luck, as any change to network config I submit apparently it doesn't even get to write any file, so doesn't appear in the logs as I saw. I'm thinking that is a low-level lock, it's quite weird that a third party sofware could enable this to my taste. Anyway is very annoying because basically the only thing I can do is change the Wi-Fi network I'm connecting to, nothing else, and even the DHCP tell the computer some DNS, they get automatically reverted to 8.8.8.8...

Any suggestions on how to keep debugging this annoying and weird problem would be appreciated.

Thanks so much in advance.

1 Answer 1

2

Did you ever resolve this? I have the same but the other way around and can't enable WiFi

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .