3

My iPhone X's (iOS 13.4) hotspot stopped giving me an IP4 address the other day. I've never had this problem in the 10 years I've had iPhones. Since Thursday, 2nd Sept 2021, I am only getting an IPv6 DHCP address whilst the IPv4 address is self-assigned. (Note I'm not talking about connecting to some Wi-Fi.)

I have tried power-cycling my phone, resetting my network settings (including changing the SSID of my phone).

Is this a carrier controlled (sim card) setting that can be remotely altered by my provider or is this something I can control on my phone? Whilst I can't find anything on my iPhone to control this, I'm wondering if I may have missed something. If it's on my phone, what can I do to fix it?

4
  • What devices are you trying to connect to your phone?
    – Logicer
    Sep 4, 2021 at 7:22
  • I have a TL-WR841N router that I use in WISP mode, and I have several devices that are only IPv4 capable. As mentioned above, everything was working fine until Thursday. I'm able to connect my MacBook Pro directly to my hotspot (though WiFi or USB) using IPv6 but I need my router to connect and receive an IPv4 address so I can use my Mac to communicate with those devices.
    – gone
    Sep 5, 2021 at 9:55
  • I have the same problem. All of the sudden, iphone's hotspot stopped assigning an IPV4 address to my PC. Did u manage to solve this?
    – tentaculo
    Dec 19, 2021 at 19:18
  • Your Telco Provider controls this setting. You will need to contact them and ask them to revert this back to an IP4 based DHCP Sever. In my case, my telco made some upgrades which included changing over to IPV6. It took less than 15 minutes for them to fix this after waiting over two weeks for the issue to be escalated to the right staff.
    – gone
    Dec 23, 2021 at 5:19

3 Answers 3

2

After contacting Apple Support and asking the right questions, I was informed that this is a setting the Telco/Carrier controls.

I then contacted my Telco and they informed me that they had upgraded some equipment and this was the new default. After negotiating with them, and waiting for over two weeks for the issue to be escalated to the appropriate staff, the issue was fixed in less than 15 minutes.

So, now I have an IP4 based Hotspot again.

2

I realize this is an old post, but ran into this issue recently connecting a MacBook Pro running MacOS 14.3.1 to a personal hotspot on an iPhone 15 Pro running iOS 17.3.1. The Mac would connect, but would not get an IP address (instead, it displayed "Self-assigned IP").

I was able to fix this by adjusting the IPv6 settings on the MacOS side:

  1. Connect to your personal hotspot.
  2. From Settings > Wi-Fi, click Details on the active connection.
  3. Under TCP/IP, set "Configure IPv6" to "Automatically" (my MacBook was somehow using "Manually", and my wife's was "Link-Local Only", both of which just wouldn't work).
  4. Click OK. It will prompt you to apply the settings, and you'll want to do that.

Once we did the above steps on both machines, they connected to the hotspot flawlessly.

1

I solved this by going to http://www.unlockit.co.nz/ and downloading a standard APN for my carrier. I toggled hotspot off and on again and boom, got an IPV4 address again :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .