1

I've recently changed my router(+NAS), Time Capsule, due to this problem, and now using new router, which is this one.

It's working very good with my iPhone, iPad, two iMac and a Mac Mini. However, when it comes to my Macbook Pro, they don't work as intended.

Before changing my router the wi-fi internet connection was very fine. So, I thought the router is having some problem, but it doesn't make sense since every other device I have is working very nicely. Then, I re-connected my Time Capsule to see if I can connect to internet with my MBP, and it works. So, I have no idea what's happening right now.

The problem is only happening with the new router, other wifi is working fine, like workplace wifi, tethering, etc...

I've checked if I'm having any error code or something but there wasn't anything I can find of. Now I don't know what to do.


Edit: So far, I've tried the solution recommended by comment below:

  • Rebooting/Resetting router. Nothing changes.
  • Resetting DNS settings. Nothing changes.
  • Deleting network related plists(Method 2)+Reboot MBP. Nothing changes.
  • Check if the problem is still occur in Safe mode. It does.
  • Check if the problem is caused by 2.4/5Ghz bandwidth. No, it wasn't.
  • Unplugged all USB devices. Still, there's problem.
  • Changed MTU to 1492. Nothing changes.
  • Tried creating new network locations. Nothing changes.

I'm only using DHCP because I use this mac when I'm not in home, such as workplace, so using a static IP address is not a very smart idea.

I am now talking with Apple to investigate what's causing the issue.

17
  • You can verify wifi preferences with this link. DNS and Proxy can be at the origin of problem s : support.apple.com/guide/mac-help/…
    – user415185
    Aug 30, 2021 at 5:09
  • Sorry I forgot to write that in my post, my DNS is 8.8.8.8 - 1.1.1.1 - 8.8.4.4 - 1.0.0.1, so I highly doubt it could be an issue. But I tried to set it default anyway, there was no change though. I sometimes use VPN but I have never used proxy. Anyway, I kind of went extreme on this: Deleted network plists, reset NVRAM, SMC, sadly no changes(again).
    – Skye-AT
    Aug 30, 2021 at 5:24
  • Which version of MacOS are you running on your Macbook? Try deactivating private address and/or set the MTU size to 1456. Aug 30, 2021 at 5:31
  • @Skye-AT If you have a VPN, you can try thirst uninstalle it. Then you can compare advanced values with the sames on functional Mac.
    – user415185
    Aug 30, 2021 at 5:39
  • 1

1 Answer 1

1

So, after a while of talking with Apple CS, we found out that the problem was on the router side...

For the reasons unknown, the router wasn't allowing my MBP to connect it. I've reset the router 3 times(again), but my MBP still didn't connect but other device can(as I wrote earlier). So, I asked for replacement of the router... and voila! it's now working.

I've wasted so many times on this, but yeah, it works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .