Why would I get the same FSCK error on 2 different external drives?

About a year ago I archived some important data (photos, etc) onto a 3TB external drive and then copied it (terminal copy command, not an image) onto a 2nd drive. The 2nd drive was stored in a different location to the first. Both drives are formatted HFS+

I recently plugged in the drive to retrieve some files and whilst the drive appears to work fine (photos all load, videos load), OSX says the drive is dirty and I get the below error when running FSCK. The drive definetely was fine last time I used it, as I ran FSCK on it before storing it.

** Checking catalog file.
** Rebuilding catalog B-tree.
hfs_UNswap_BTNode: invalid node height (1)
hfs_swap_BTNode: offset #0 invalid  (0xFC11) (blockSize 0x2000 numRecords 24)
   Invalid node structure
(4, 12830)
** The volume 3TB could not be repaired.

Now it gets weird as I just checked the 2nd drive and it has exactly the same error in FSCK despite being a different model (seagate vs WD) and it wasn't created by image, it was populated by an OS level file copy.

I don't need help getting the data off it, but I love to know why or what is going on here? My extensive google search turns up either "physical issue", or "just run disk warrior". Whilst possible, I doubt its a drive hardware issue. Could it just be a bad file on the disk? Or a hardware issue with the USB interface (yes I have tried different cables)?


  • 1
    This really doesn't provide an answer, nor is it even a truly related issue, but as one of a series of ongoing issues with Time Machine [eventually solved years later with a migrate, links if you really need them] I had this - apple.stackexchange.com/questions/328358/… - ironically periodically fixed by DiskWarrior, then broken again by the OS. I never did find out what was causing it & only eventually fixed it this year.
    – Tetsujin
    Commented Aug 29, 2021 at 11:03
  • 1
    Thanks. I am also still on High Sierra, I wonder if that has something to do with it.
    – Rob P
    Commented Aug 29, 2021 at 23:11
  • tbh, I don't know - nor do I truly know how I eventually fixed it, except it required much juggling & a migrate over ethernet to a new OS [which needed two almost identical Macs to finally achieve]. Several linked topics over the years also seemed to completely flummox the rest of Ask Different ;))
    – Tetsujin
    Commented Aug 30, 2021 at 14:43
  • 1
    I'm checking the hash of each file on both drives using the method described here: unix.stackexchange.com/questions/395778/… I will then be migrating onto a Synology NAS with RAID. This issue has pushed home the need to take data integrity seriously. Once all of that is done, I may come back to this by reformatting the drives and trying again to see what happens.
    – Rob P
    Commented Dec 9, 2021 at 23:59


You must log in to answer this question.

Browse other questions tagged .