2

I have installed GNU findutils via Homebrew and I use glocate to create a locate database.

The following command worked perfectly under macOS High Sierra:

sudo gupdatedb  --localpaths=/ --prunepaths=/Volumes --output=~/locatedb

However after upgrading to Catalina (and upgrading all Homebrew formulas including findutils), I get with the same command the following error:

gfind: failed to read file names from file system at or below '/': No such file or directory

Any idea how to fix this? I suspect it has to do the tighter security under Catalina.


(Also, I have read macos - GNU version of locate - gupdatedb fails with "gfind: failed to read file names from file system" - Ask Different and I am making sure that the gfind command is used not th find command, but I still get the error message.)

1 Answer 1

1

The error message is caused by (g)find traversing the /System directory. Exclude this directory and the indexing completes without an error:

sudo gupdatedb  --localpaths=/ --prunepaths="/Volumes /System" --output=~/locatedb
1
  • Very useful! But watch out, the tilde in --output=~/locatedb won't expand because it's not at the beginning of the word. Try --output=${HOME}/locatedb Commented Jul 26, 2023 at 10:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .