I am trying to help a senior about 500 miles away who is having serious problems with his MacBook Pro. He lives hours away from any Apple stores and any convenient sources of computer help.

Here’s the situation: He has a MacBook Pro (Retina, 13-inch, Late 2013) Model A1502 running Big Sur 11.2.3.

He has a 500 GB internal SSD that is slightly less than half full.

The problem began when Mail quit with this alert: <Mail cannot save information about your mailboxes because there isn’t enough space in your home folder. Quit Mail and delete any files you don’t need. Then open Mail again.>

I researched that and found the suggestion to reset the NVRAM and do a Safe Boot. After doing so, Mail was fine for one day and then the situation repeated with the same alert and Mail quits.

While sharing desktops, I noted the red number 4 on the App Store icon in his Dock. We went to the App Store to update four apps and when we tried to do so we got this alert: <Installation failed. Can’t install the software because there is not enough space. 4.81 GB is needed but only 407.8 MB is available>. This is of course non-sensical because he has well over 300 GB of free space on his internal HD.

We tried to download the Maintenance.app from Titanium Software and when we did so and dragged the apps icon into the Applications folder, it would not work noting that more space was needed.

And now it gets even more bizarre. I could see that something serious was wrong and wanted to be absolutely sure he had a good backup before proceeding.

I had him attach an empty, 500GB OWC SSD and go to Time Machine preferences, and unlock them, in order to select the attached OWC SSD for use with TM. Even though we could view that OWC SSD icon on his desktop and view it in Disk Utilities, I could not get it to appear in Time Machine preferences so we could initiate a backup.

Using Disk Utility to view that OWC SSD, it listed: External USB 3.0 Media Container disk4 OWC Auro Pro X2 ASRDataVolume2.

I selected each of the above in turn, right clicked on each, ran First Aid, and all passed.

I also looked up Apple Diagnostics Test and told him to restart holding down the D key and note the results, codes, etc. Will post the results here later.

I simply don’t know what to do at this point and really need some help and guidance, for which, many thanks.

  • 2
    Where are you reading the free space from? Does it show up in Disk Utility?
    – Ezekiel
    Aug 28, 2021 at 14:55
  • Just to ask some obvious questions: (1) Have you booted into Recovery mode to run Disk Utility's First Aid on the boot volume? (2) When you were booted into Safe Mode and it ran fine for a day, did the problem reoccur while still booted in Safe Mode, or had you rebooted into normal mode by then?
    – pion
    Aug 28, 2021 at 20:49
  • Answers are No for (1) and for (2) I had him boot into Safe Mode then do an immediate reboot because I saw it recommended on another site. We did not run it for any length of time.
    – Penny11
    Aug 29, 2021 at 15:17
  • Forgot to add: we are reading his free disk space from About This Mac, Storage.
    – Penny11
    Aug 29, 2021 at 15:18
  • I just emailed him and asked him to do a Get Info on his Internal SSD and send me the screenshot.
    – Penny11
    Aug 29, 2021 at 15:23

3 Answers 3


There are probably local snapshots on the data partition which is not accounted for in About My Mac > Storage. Use df -h or diskutil apfs list to view the actual disk space.

To list all Time Machine local snapshots, use tmutil listlocalsnapshots / or diskutil apfs snapshots / (much slower).

This command will delete all snapshots (in most cases):

tmutil thinlocalsnapshots / 9999999999999 4
  • I will share desktops with him later today and run those Terminal commands. I just did them on my own iMac and see what you mean. Will report back.
    – Penny11
    Aug 29, 2021 at 15:31
  • In the next version of macOS (Monterey) coming this fall, there will be a UI to manage these snapshots too
    – Ezekiel
    Aug 29, 2021 at 16:14
  1. Quit Mail.
  2. Click on the Desktop and press the keys command+shift+G.
  3. On the Go to Folder window copy&paste the path· /Users/your username/Library/Mail/V8/MailData/Envelope Index and click Go.
  4. Drag the highlighted file (Envelope index) to the bin.
  5. Relaunch Mail, the file will be recreated.
  6. Test.

enter image description here (

  • Got it, and thank you so very much. If it turns out that our suspected fix doesn't persist & the problem returns, I will have him follow the instructions you sent.
    – Penny11
    Aug 29, 2021 at 15:44
  • You are welcome.
    – George
    Aug 29, 2021 at 15:52

Is this the error message ?. If yes, there is probably corrupted the Mail Index. There is a solution.

enter image description here

  • That is exactly the alert he got: I saved a screenshot of it. Can you link me to the solution? In just a moment, I will add another comment for what we did that appears to have fixed his problem...at least for about 12 hours.
    – Penny11
    Aug 29, 2021 at 15:37
  • Part I - Let me tell you what seems to have worked. One guy said: try either OmniDiskSweeper, DaisyDisk, Grand Perspective. Sometimes it's a bloated log file from a runaway process. Sometimes it's a bunch of iPhone backups in ~/Library/Application Support/MobileSync. If the spotlight index is messed up, it can sometimes cause the Finder to misreport the amount of open space. You can use tools like Maintenance or OnyX to force a rebuild of the Spotlight index. Running ONYX & rebuilding the Spotlight Index seems to have done it.
    – Penny11
    Aug 29, 2021 at 15:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .