2

When I run lsof I get this warning:

lsof: WARNING: can't stat() smbfs file system /Volumes/.timemachine/DS920._smb._tcp.local/D218965D-0155-4757-AB63-B9036A3B29C8/Time Machine Backup - MyName
      Output information may be incomplete.
      assuming "dev=34000202" from mount table

I found lsof: WARNING: can't stat() fuse.gvfsd-fuse file system on Unix & Linux SE, but the suggested solution to use the -e option doesn't work on macOS as it is only implemented for Linux:

       +|-e s   exempts the file system whose path name is s from being subjected
                to kernel function calls that might block...

                This option is currently implemented only for Linux.

I know you can use -w to suppress warnings, but I only want to suppress this one warning, not any other potential warnings.

Is there a way to exclude my Time Machine volume from lsof or otherwise silence this warning without having to do something like lsof 2>&1 1>/dev/null | grep -Ev "can't stat\(\) smbfs file system /Volumes/.timemachine|Output information may be incomplete\.|assuming \"dev=\\d+\" from mount table"?

2
  • 1
    It clearly states: "This option is currently implemented only for Linux." In the interim, try disconnecting from your Time Machine volume before running lsof. Commented Aug 27, 2021 at 4:11
  • 1
    @user3439894 Yes I am aware it's not implemented for macOS; that's why I included that section of the man page. Commented Aug 28, 2021 at 3:28

0

You must log in to answer this question.

Browse other questions tagged .