1

Following these instructions I closed the Notebook in OneNote for Mac (version 16.52), renamed the Notebook in OneDrive and re-opened the renamed Notebook in OneNote for Mac. Unfortunately the rename is ignored by OneNote for Mac and then the synchronisation fails immediately after opening as the Notebooks are inconsistently named.

Sync error:

This section might have been deleted from the server. You can try to sync this section again, or copy your notes to another section.

I have tried to open the Notebook in OneNote online: the Notebook opens correctly and shows the correct new name. I have deleted the Microsoft OneNote container in my user Library, plus any other reference I could find in my user Library related to Microsoft OneNote. I have tried closing the Notebook in OneNote for Mac, opening in OneNote online, make changes in the Notebook so that it forces a synchronisation, and then re-opening the Notebook in OneNote for Mac. The update made in OneNote online shows on the Mac, however changes on the Mac are not synchronised back to the online repository of the Notebook due to above error.

1 Answer 1

0

This is weird, I'm not sure how this worked for me, but... Essentially, I had exactly the same issue (renamed the "file" in OneDrive, opened the new file name in OneNote, but the old name was retained and synchronising updates failed). I then took the following steps:

  1. I closed OneNote, went to OneDrive and copied the notebook to a new name. Opened OneNote, tried to open the new notebook, but OneNote couldn't even see it.
  2. Closed OneNote completely.
  3. Repeated steps 1 & 2
  4. Opened OneNote again, and there it was - the original renamed version (the one I was trying to open & sync originally, not the copy), and syncing looked okay. I opened it (not the copy) on the web, and my changes were synchronised.
  5. I deleted the copy via OneDrive.

I know - it's a reall "turn it off and on again" kind of thing, but there you are.

2
  • Welcome to Ask Different SE and thank you for your contribution. When you get a chance, please take the tour to understand how the site works and how it is different than others.
    – agarza
    Sep 2, 2021 at 3:39
  • These very specific instructions didn't work for me, however at one point in all the different resets I have done over a few weeks period suddenly it started working. So I'd say the answer is mostly: "it's a real "turn it off and on again" kind of thing" Dec 6, 2021 at 0:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .