0

On my iPhone 6s the Messages has been enabled to be accessed via iCloud :

Screenshot of the iCloud screen on an iPhone

Then I logged out of/back into my AppleId on the MacBook Pro with Big Sur. But the Messages still does not show up in Apps on this Mac using iCloud under System Preferences > iCloud :

Screenshot of the top-half of Apps on this Mac using iCloud window on macOS

Screenshot of the bottom-half of Apps on this Mac using iCloud window on macOS

In addition "Text Message Forwarding" to that mac is enabled on the iPhone settings:

enter image description here

What else needs to be done?

Update Messages that are created on the Mac are being correctly synced /viewable on the iPhone. But messages originating on the iPhone are not synced/visible on the Mac

1

For whatever reason, Apple decided some apps should use System Preferences to control their iCloud syncing and others should it themselves. For Messages (and FaceTime) on the Mac, iCloud sync settings are located within the app's preferences, where you are given the option to Enable messages in iCloud and to Sync Now. This is the Mac equivalent to what you've done on your iPhone.

iMessage Preferences Pane

2
  • Thanks for the heads up on this. In my case the "Enable Messages in iCloud" had already been enabled so I clicked on "Sync now". The missing messages subsequently appeared Aug 25 at 13:20
  • This is a helpful answer but actually is not working reliably on my Mac (Big Sur). I have signed out/in to appleId, restarted Messages, hit "Sync now" again .. Newer messages are again not being sync'ed. Frustrating Aug 25 at 16:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .