1

I use Firefox as my default browser on macOS Catalina version 10.15.7. Yesterday I used brew to upgrade Firefox to the latest version:

brew update
brew upgrade firefox

After the upgrade, Firefox works normally when I open it from applications menu. It is the latest version: 91.0.1 (64-bit).

However since the upgrade, links in my mail through the Apple Mail app don't open. When I click on them, nothing happens. If I right click the link and select "open with" and choose Firefox, I get a dialog that says:

You can't open the application "Firefox" because the Classic environment is no longer supported.

When I search for this error message, it appears to be related to application that are not compiled for macOS. I shouldn't think that would apply to Firefox.

It appears that a second older version of Firefox 89.0.2 was still installed on my system in /usr/local/Caskroom. I found it with the command locate firefox and then I removed it, but it didn't solve the problem. locate firefox and locate Firefox now only show firefox installed in /Applications/Firefox.app

What is causing this error and how can I fix it?

Update

This has something to do with brew. I just tried installing Google Chome from brew because it also needed to up updated. (Neither Firefox nor Chrome have the permissions needed to update themselves.) I used the -f flag to force brew to overwrite the version of chrome that had been installed in some other way:

brew install google-chrome -f

After installing Chrome from brew, Mail can't open links in it either with the same message. Is brew putting some wrapper around these applications that is using classic mode?

5
  • 3
    Is there a particular reason you are not just installing Firefox using their point-and-click Firefox installer? mozilla.org/en-US/firefox/new Aug 20, 2021 at 13:01
  • Why wouldn't I use a package manager? I don't want to have to download and install software manually then have to continually repeat the process to keep it up to date. Aug 20, 2021 at 13:03
  • 2
    Firefox (and many other apps) include self updating mechanisms so you don't have to do it manually - either choose fully automatic or choose just press a button when Firefox tells you there is a new version
    – mmmmmm
    Aug 20, 2021 at 13:34
  • 2
    Firefox 91 has tried to use different Apple systems calls and has messed up loading CSS bugzilla.mozilla.org/show_bug.cgi?id=1725436 Has this also broken other macOS integration. Report this to Mozilla as a bug. Firefox does not use standard Apple program APIs but is cross platform and uses lower level ones that do not do all a normal app does.
    – mmmmmm
    Aug 20, 2021 at 13:51
  • Does this still happen with later versions of Firefox - they removed the code that changed the macOS behaviour.
    – mmmmmm
    Jan 23 at 14:50

1 Answer 1

1

Manually downloading and installing Firefox and Chrome is a workaround for this problem. It is only when they are installed by brew that there is a problem. I'm not sure what the difference is when install via brew vs installed by the downloaded .dmg

The self updating mechanism mentioned in the comments doesn't work for me. Firefox will tell me that an update is available and offer to download it, but when I click the download button, the dialog goes away and Firefox doesn't get updated.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .