0

An Automator task runs an rclone script for backups. This is scheduled in the Calendar. It worked fine in Catalina, but just when I upgraded to Big Sur, I started seeing these alerts whenever the script was supposed to run. The script runs fine from the terminal.

It appears that Automator (or at least "Automation", the closest I could find) has permissions.

How can I allow rclone to run?

enter image description here

enter image description here

enter image description here

3
  • 1
    It's probably a result of the increased security that prevents users from running their software. ;-) Check that rclone does launch without incident in the Finder. You may need to add Automator, or sh, or something to some of the System Preferences Security's panels. I suggest Full Disk Access, and Developer Tools. See if anything in Automation needs ticking, too.
    – benwiggy
    Aug 13, 2021 at 13:34
  • Thank you. The rclone script runs fine from the Terminal. It appears that Automator (or at least "Automation", the closest I could fine) has permissions. See screenshot above. How else would I give permissions to Automator?
    – Joshua Fox
    Aug 13, 2021 at 14:31
  • Deleting everything and redoing the whole Automator alarm solved this. Makes no sense, so I attribute this to changes in the Big Sur security model that I do not quite understand.
    – Joshua Fox
    Aug 24, 2021 at 16:41

1 Answer 1

0

Deleting everything and redoing the whole Automator alarm solved this. Makes no sense, so I attribute this to changes in the Big Sur security model that I do not quite understand.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .