2

I have a mid-2014 15-inch MacBook Pro Retina. I was using it half an hour ago, and everything worked perfectly. I turned it off and left it for five minutes or less. I turned it back on to check something I forgot, and now it won’t boot. the little progress bar underneath the Apple logo fills in much slower than normal, and the computer turns off when the progress bar is about 2/3 full.

  • Battery is fine. The computer was plugged in before I turned it off, so the battery is full, and it’s plugged in now.

  • I have a Windows partition I can boot from with no problems since the Mac problem started.

  • Trying to start in safe mode results in either a black screen indefinitely or the computer turning off when the progress bar is maybe 1/10 full.

  • Trying to start in diagnostics mode results in a black screen indefinitely.

  • Tried resetting the system management controller. Nothing changed.

  • Tried resetting the PRAM. What happened is the Mac kept restarting every five seconds or so while I kept cmd+alt+P+R held down and then returned to the above problem when I let go.

If it helps, the internal SSD is a 960-GB Aura drive with two partitions: 760 GB with Catalina and 200 GB with Windows 10. It is not the internal drive that came originally with the Mac, but the replacement was made several years ago and I’d never had a problem with it before.

3
  • Can you boot in verbose mode (Command+V during boot), take a slow-mo video of the boot process, and upload it somewhere (like pastebin.com) so we can take a look at the console output and see where it hangs?
    – pion
    Commented Aug 4, 2021 at 21:12
  • Try Apple Diagnostics (startup holding D)? Try single-user mode (command-s)? Try reinstall?
    – Joy Jin
    Commented Aug 6, 2021 at 12:45
  • As mentioned previously, diagnostics mode doesn’t work. Other things did, sort of; will post an answer.
    – Rain
    Commented Aug 9, 2021 at 9:52

1 Answer 1

1

2021.08.09

It’s the internal drive. It’s damaged. Turns out those things have a lifetime of about 5 years and I’ve had mine for 4 (and I use it heavily).

Strangely, recovery mode did work. Here’s what happened when I managed to boot in recovery mode:

  • Running first aid on my Mac partition returned a bunch of errors and failed.
  • I tried reinstalling the OS, but that failed after the progress bar reached the end.
  • I then tried restoring from Time Machine, which failed about a third of the way through.
  • I tried reinstalling the OS again, but it wouldn’t let me on account of there being insufficient space (there wasn’t insufficient space); restarting and going into recovery mode again fixed this issue, but it still wouldn’t install because of the same error as before.
  • I then tried erasing the drive in order to remove whatever it was that was causing the OS reinstallation to fail. That failed too… but apparently it did erase some important system files, because upon restart the computer no longer recognised the Mac partition as a bootable drive (it would boot directly to Windows, and holding down alt would only show the Windows partition). Thankfully, recovery mode continued to work.
  • Trying to reinstall the OS failed because the Mac partition was now an “incomplete drive”. I imagine the poor partition must have been in a state similar to Dresden after it was bombed, with some things still there and other things half-deleted or completely deleted.
  • I tried to erase the partition again, which this time worked for whatever reason.
  • Now I was able to reinstall the OS followed by restoring from Time Machine.

My computer now works, but I have three colies of Macintosh HD in my Volumes folder, two of which contain only system files and one of which contains everything restored by Time Machine. I imagine the former two are leftovers from reinstalling the OS and/or erasing the partition (the recovery-mode bootable files have to live somewhere, right?).

At this point, I’ve purchased a new SSD to replace my current one with (waiting for it to arrive in the mail) and I’m in the process of uploading my most important stuff to iCloud. Will update if anything changes, but that should fix all of my computer-related problems.

2021.08.26 update

So far so good. New SSD runs without a flaw and copies data as quickly as Usain Bolt does the 10 m. Uploading to iCloud took forever because 160 GB but works really nicely except for it having screwed up my smart folders (will have to create them again at some point). Will keep updating as more time passes.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .