3

Apple shows no consideration for the user with this update. Older versions of macOS did not include as many notifications. Big Sur claims that:

Notification Center shows your alerts in the upper-right of your screen, without interrupting what you're doing. Show and hide Notification Center by click the clock in the menu bar.

And Notification Center, in theory, lets you disable notifications for a given program.

Problem is: there is visibly no way to disable notifications for ALL programs by default. So any time you launch a new program you still get notification spam like this:

Notification Center spam macOS Big Sur

It's distracting, breaks my focus, and makes the mac feels like a phone.

In addition: for a program whose notifications are disabled, whether the calendar style is set to "None" or "Banners" still seems to make an impact. If a program's notifications are disabled, I seem to still be getting a notification like the above the first time I launch it, except if I set its style to "None" beforehand.

That's a lot of time and attention wasted. Ergo:

How can I set notifications to disabled/"do not allow" and/or their alert style to "None", by default, for all programs?

Running Big Sur 11.5.1.


There are already related questions here and here, but I find them poorly phrased, with a focus on fixes that worked for older versions of macOS (Catalina) but no longer work.

2
  • How about setting Do Not Disturb forever?
    – lhf
    Aug 2, 2021 at 13:05
  • @ihf That's what I was thinking... But I still want to use the Calendar. Aug 3, 2021 at 15:29

0

You must log in to answer this question.

Browse other questions tagged .