1

I have a bluetooth headset that I use for an Android phone and a MacBook. It has the feature of being able to connect to both at the same time, and switch to whichever one is actively playing. There is no mixing, the audio is just "stolen".

However, when some audio applications idle, they will "steal" the audio. So, if I'm using my phone, and the MacBook will come into range while Spotify is open (but not playing) it will pause playback on the phone and switch to the MacBook. This is because once the headset is in range, macOS automatically connects to it and then switches the default audio device to it.

So far in Big Sur I've not found an option to disable it. This question has a solution that works for previous versions but not Big Sur.

It will even switch audio devices if I have wired headphones connected!

Is there some workaround I can use for Big Sur?

1 Answer 1

1

To turn off automatic switching, you will need to be on the device your AirPods are currently connected to.

Instructions for an iPhone or iPad

  • Open the Settings app, and select Bluetooth

  • Tap the Info icon next to your AirPods, and look for Connect to This [Device]

  • Change the connection option to When Last Connected to This [Device]

Instructions for a Mac

  • Open the System Preferences application.

  • Select Bluetooth and then choose Options next to your AirPods.

  • Next to Connect to This Mac choose When Last Connected to This Mac

  • When this option is selected, your AirPods will automatically connect to the last device they were manually connected to, and will not switch to another device on their own.

One important thing to note: You will need to take the above steps on each of your devices, or at least the devices you don’t want your AirPods to automatically switch to. For example, you may want your AirPods to automatically switch to your iPhone, but not your Mac. In that case, you would need to take the above steps for your Mac, but leave automatic switching enabled on your iPhone.

1
  • I'm afraid that this answer only works for AirPods, which these earphones are not :(
    – Adi
    Jan 14 at 7:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .