0

I am using an iMac (21.5-inch, Late 2011) with High Sierra 10.13.6. I have installed Windows 7 SP1 via Boot Camp and a bootable disk. It was working fine.

So the other day, I decided to create a new partition on Windows using Windows 7 SP1 and it did warn me that I can only boot an OS from this partition. It did create a new partition (usable). I then checked the Boot Camp help system and it said that there was only 1 startup disk I could use, which is labeled Windows. And that is how I know i have made a big mistake. The following day I proceeded to hold down the option key while starting the iMac and normally it would show 3 options: Windows, macOS 10.13.6 and Recovery 10.13.6. (I am not sure about the names.) But, now it only shows the Windows option. So, I then restart my mac into Internet Recovery mode and it just stuck at ETA 24:00. It wont even move after 1 hour, and it gives me an exclamation mark in a triangle over the globe. Can you guys help me fix this please. I have tried to reset the NVRAM and PRAM, but it is still the same. I think it is because of my internet slowness, but there has to be another way right?

1
  • Have you an another Mac to create an Install USB Key?
    – user415185
    Jul 30, 2021 at 7:05

1 Answer 1

0

You need to post the current values in the partition tables. To do this from Windows, you need to use a third party command called gdisk64.exe. This can be download from the project gptfdisk.

  1. Boot to Windows

  2. Download from gptfdisk.

  3. Extract gdisk64.exe.

  4. Open a Command Prompt window as Administrator.

  5. Change to the directory containing gdisk64.exe

  6. Enter the commands below.

    Note: gdisk64.exe is a interactive command.

    gdisk 0:
    r
    o
    p
    q
    
  7. Post the output to your question.

3
  • When i tried to boot into Windows it shows me the Windows Recovery Error thing with 2 option: to launch Start up Recovery or to start Windows normally. I went with the second option the first time and after the logo appeared it flashed a blue screen with a bunch of texts on it and shut itself down and restarted. After tryung multiple times, the result remains the same.Now im not too sure what to do and im afraid that the 1st option would somehow damage my mac even further so i havent tried anything yet. Should i launch Start up Recovery or should i do something else ? Jul 30, 2021 at 11:35
  • Do you have access to any other computers? If so, what operating systems are installed on the computers. Do you have any Windows or OS X installation DVD's. If so, which? Jul 30, 2021 at 12:31
  • I can borrow my friend's Pc which run Windows 10 and i do have a DVD-RW 4.7gb, is that good enough? Aug 2, 2021 at 6:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .