0

My machine has MacOS Big Sur 11.4 with silicon chips. I'm attaching two screenshots here. Whenever I start a new terminal, it appears like this one. this one. Termination of terminal The terminal shows the running process which is 'zsh > sleep'. Second screenshot shows when I'm closing the terminal window even without running any process manually. Where have I gone wrong? And how should I terminate this process permanently (atleast for the time being for initiation of terminal).

Please help!!. I'm at my wit's end.

2
  • I think you'll find that all computers have silicon chips in them :-)  I guess you mean ‘Apple silicon’, i.e. Apple's range of ARM-based chips.
    – gidds
    Jul 31, 2021 at 17:50
  • There is a sleep .... & in some of your startup files. Change the configuration of your terminal preferences, so that zsh is executed with the -x option. This should show you where the sleep is ... eh ... sleeping; and be glad that the chips of your Apple are made of silicon, and not of potato salad. ;-P Jan 23, 2023 at 10:38

1 Answer 1

1

Based on this limited information, my guess would be that you have executing sleep somewhere from your zsh config.

To view your zsh config, open ~/.zshrc:

open ~/.zshrc

If you find sleep in there, you can try removing it and reloading your zsh config with:

source ~/.zshrc
1
  • there was no sleep in text editor but i found an unknown line in text. removed it and now the terminal is good. thanks for the heads-up.
    – Bot
    Jul 29, 2021 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .