MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports) / macOS Big Sur 11.4

I'm experiencing a weird WiFi issue at our remote office where I'm only able to connect to IPv6 addresses and not IPv4 addresses. Ping does not work, ping6 works. Local DNS works as ping6 resolves correctly. I can access google.com in my browser (resolves to an IPv6) but not stackoverflow.com (resolves to an IPv4).

Network settings

I've tried rebooting both my machine as well as the router. My iPhone works correctly on the network and shows similar values for the network addresses. My mobile hotspot works and other WiFis work on the Macbook. Internet is working for everyone else and everything was working fine in May when I last connected to this network (I did update from Mojave to Big Sur in the meantime but otherwise the set-up should be the same).

I've tried switching IPv6 to link-local only, configured IPv4 manually, removed external DNS addresses, disabled all proxies, turned the firewall off, flushed the DNS cache, booted to safe mode, disabled IPv6 completely via Terminal, uninstalled NordVPN, and done other things I don't even remember anymore and I've run out of things to try.

I don't have access to configure the router, but aside from that does anybody have any ideas?

  • Your laptop has not successfully configured with DHCP. The IPv4 address 169.254.x.x is a link local address and will not (should never) have been given out by your router. Note that there is no "router" configured under IPv4. Have you tried the obvious thing of clicking Renew DHCP Lease? Commented Jul 27, 2021 at 11:33
  • Thanks @PhilipCouling! Yes, for sure I've endlessly clicked on renew DHCP lease with no success :(
    – jarsta
    Commented Jul 27, 2021 at 13:24
  • I also have this problem since upgrading to Catalina from High Sierra. Although the manifestation is different as the Wi-Fi sharing of my other macbook don't have IPv6, so I can't access anything. But using ethernet seems to work.
    – Joy Jin
    Commented Mar 22, 2022 at 0:32
  • Seems like the router is not running as a DHCP server (on wifi). Do you know the IP4 address of the router? If so, you could just select a random address in the subnet.
    – Gilby
    Commented May 24, 2022 at 11:58
  • Similar issue here on my MBP 2021 14-inch M1 Pro. For the record, I'm a network engineer by profession, so the first thing I checked was that DHCP wasn't to blame (it isn't - at least in my case). The issue for me is that the laptop is not requesting an address from the DHCP server, not that one isn't being supplied. And, just as you described, IPv6 keeps working without any issues when this happens. It seems that there's some sort of bug with the IPv4 stack in macOS. From my own testing, a reboot is the only thing able to get functionality back. Restarting the adapter changes nothing.
    – Jesse P.
    Commented Aug 21, 2022 at 23:34

3 Answers 3


There’s not much you can do without outside help when the network is not supplying IPv4 via DHCP and your attempt to manually find a working gateway and DNS fail.

I would probably reach for a VPN to get away from that subnet, but presumably you’re on this network for more than just internet access?

Engaging with the support organization for this office network may be the correct next step after running out of any other alternatives.


I had an issue with the same symptoms after I upgraded to macos 12.5. Specifically any network interface (wifi, wired, or iphone-tether) would only get an IPv6 address and not an IPv4 address.

This was on my work Macbook Pro (M1), and I am fortunate enough to have got through to a knowledgeable IT support rep, who went through a barrage of troubleshooting steps. The action that worked in my case was:

  1. In /Library/Preferences/SystemConfiguration/, move the following files to a Desktop folder:
  1. Reboot

After that, I was able to get DHCP IPv4 addresses again and IPv4 networking worked as expected.

  • 1
    This problem showed up for me after updating from MacOS Ventura 13.3 to 13.4. After a reboot didn't fix it, I found this thread, and decided to test those files one at a time, since it seemed unlikely that all five were causing problems. I got lucky. On my first try, I deleted preferences.plist and rebooted. IP4 was once again working. Commented Jun 5, 2023 at 12:28
  1. Go here:


  2. Delete preferences.plist, then reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .