0

I run into this problem constantly, across all manners of applications, and I'm beginning to think I'm just not doing something correctly.

Basically any and all mac keyboard shortcuts mostly don't work for me, and the problem is extremely apparent when the keyboard shortcut involves using 2 keys + cmd key.

For example, I am using IntelliJ right now, a java editor. I can use cmd and + to collapse a single function. Cmd, a, and + should collapse all functions. The former works, the latter selects everything and does nothing else. Up + cmd + a is supposed to open the "find action" dialog; instead it opens a random drop down for selecting a file in my project. I've tried pressing the keys simultaneously, in all sorts of sequences. Almost every application I touch has this issue. If the 3 key combos do anything, it's never what they say they'll do. Snag it screenshots? Nope. Redo action? Nope. You name it, doesn't work.

Please help. I'm tired of clicking through window options like someone who just took their first course at the library in computer literacy. I used to do literally whatever you could imagine with Windows and barely even need a mouse at all.

5
  • 1
    Two 'alphanumeric' keys + Cmd?? I've never heard of such a thing. I found a shortcut cheat sheet - shortcutfoo.com/app/dojos/intellij-idea-mac/cheatsheet - which also doesn't mention this.
    – Tetsujin
    Jul 21 at 15:28
  • @Tetsujin I have just learned that the Up arrow is actually meaning the shift key. So it's cmd+shift+a, not cmd+up+a. I'm going to set aside how infuriating this is for a moment to ask you a follow-up. Knowing this I can now collapse/expand all, but when I do a cmd+shift+a to open the find action dialog, it briefly opens and then randomly a terminal pops up. Can you explain why?
    – sprmap
    Jul 21 at 15:31
  • 1
    Have a look at the cheat sheet to see what the commands should be. Find is Cmd/F. I don't use IntelliJ, so idk what its defaults are, but many "terminal" & IDE apps have their own rules that don't follow the standard Mac Toolbox. For instance the Mac has nothing like Cmd/A/+ it's just not a valid key command.
    – Tetsujin
    Jul 21 at 15:36
  • Where are you seeing these key stroke. Expand all is shift and cmd and +
    – mmmmmm
    Jul 21 at 21:01
  • <kbd>⇧</kbd> <kbd>⌘</kbd> <kbd>+</kbd> - Put that in your question and is that what you saw (comments don't allow markup) ie the shortcut is ⇧⌘+ .
    – mmmmmm
    Jul 21 at 21:05
0

The answer is that the up arrow means "shift", not "up directional key", when Mac applications list shortcuts. Apple's Guide to these symbols is here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .