4

Is there a way to stop autocorrect from altering words that I spell correctly? While still keeping autocorrect on for incorrectly spelled words.

Some examples off the top of my head, but there’s plenty more stupid stuff it does:

I will do it today > I Will do it today

(it thinks I mean a person called Will)

Bus stop > Bud stop

(who knows!)

St Albans > At Albans

(a city near London)

I’ve ticked off the ones that are done > I’ve ticket off the ones that are done

(✅ vs 🎟)

Let’s see if they say yes > Let’s see of they say yes

(Totally wrong)

I have tried turning off Autocorrect in Settings > General > Keyboards; but this disables autocorrect completely. The words still pop up above the keyboard but it no longer autocorrects just by typing.

It can be quite frustrating to have iOS randomly change your sentence to something that doesn’t make sense because it thinks the grammar might be wrong or it’s trying to second guess what you’re typing, when I’ve typed something completely valid.

Adding endless lists of words that iOS constantly wants to “correct” into the Keyboard Text Replacement option is not a solution in my opinion. The list of correctly spelled words that iOS likes to alter is vast. Also I already use the Keyboard Text Replacement feature extensively so I don’t want my own list polluting with this nonsense.

Surely there is a way to not autocorrect correctly spelled words?

If not is there any app or Shortcut that bypasses this somehow?

Is it “learning” these somehow? It seems to go through phases of changing certain words for a while until I correct it enough times.

1
  • It does seem to learn if you correct it often enough. I don't know the mechanism by which it does this.
    – Tetsujin
    Commented Jul 21, 2021 at 5:14

3 Answers 3

1

You only have to look at any of the webpages listing amusing autocorrect instances to see how problematic it is.

I find it much more useful for the phone to offer 'suggestions' of words, above the keyboard, as I'm typing, instead of automatically changing what I've already written.

That way, it's one tap to complete or correct a word, once it's one of the options, and I don't end up with any problems when the phone ducks my ship.

So under Keyboards: turn "Auto-Correction" OFF and Predictive ON.

1

So this problem became so bad for me that I spoke to Apple and we were able to figure out the steps needed to make your device unlearn words it gets wrong:

  1. Go to Settings > General > Keyboard > Keyboards
  2. Ensure only the official keyboard is installed (your region + Emoji)
  3. Back to General
  4. Go to Dictionary, then remove all dictionaries, then add just Apple Dictionary + your region
  5. Back to General
  6. Go to Transfer or Reset iPhone > Reset > Reset Keyboard Dictionary
  7. Enter your passcode
  8. Confirm the final warning
  9. Restart

Problem solved!

This does not clear your Text Replacement list, so don’t worry about that (it’s synced to all devices via iCloud).

If you’re particularly worried, you could manually back up your device first in Settings > iCloud (your name) > iCloud > iCloud Backup > Back Up Now.

No more accidentally saying “I’m going to get a bud” when I’ve typed “I’m going to get a bus” 😅

0

There are few solutions, but none of them are too great. You could disable autocorrect entirely. You could add text replacement for a few of the most annoying corrections. Another option would be to use an alternate keyboard. Some keyboards have autocorrect that might work better than the system keyboard. I don't have any specific recommendations because I use the system keyboard myself, but there are several popular ones.

1
  • Using an alternative keyboard carries its own risks (think keylogger) Commented Aug 5, 2021 at 11:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .