3

I have a Canon MF4770n printer/scanner connected via Ethernet to the home network, and a Mac running Mac OS 10.14.6.

Previously (for years), I could open Image Capture and choose the scanner and thereby scan images to my computer either from the flatbed or the document scanner.

Although the print capabilities still work, AND the scanner still shows in the list in the Image Capture utility, I now get the following error when I actually click the "scan" button in Image Capture:

Scanner reported an error

Cannot communicate with the scanner.
The cable may be disconnected, or the scanner may be turned off.
Check the scanner status and try again.
Scanner driver will be terminated.

Error code: 600104

What's even more interesting, if I click the scan button on the computer without anything in the document feeder, I just get a message that there's nothing in the document feeder. So the scanner is definitely connected. This is repeatedly reproducible.

How can I troubleshoot?

5
  • can you give us a quick rundown on what you're tried (Firmware update, restarting, force resetting settings, etc)? Does this issue affect other computers or just yours? Is this only over the network, or do you get errors if you attempt to use the scanner over USB? Aug 20, 2021 at 22:21
  • @ToddDabney unfortunately I don't recall everything I tried, but restarting for sure, and I think removing and re-adding the scanner as well. It's not feasible to connect the printer via USB and I never had to before. The other computer I could try scanning from is running Linux Mint; I tried but had never done it before so it's inconclusive whether it is just not set up right in the first place or is having a similar error.
    – Wildcard
    Aug 20, 2021 at 22:34
  • 1
    Sorry that I can't help you with your problem but I will up-vote your question because reading it helped me learn that there was an Image Capture utility coming with macOS (and it still seems to work with my scanner). I also have a Canon printer/scanner (a different one) I bought seven years ago and have been a macOS user for about ten years. Until today, I have always used the utility that came with the printer whenever I needed to scan something. Thx!
    – Alper
    Aug 24, 2021 at 2:02
  • @Wildcard you can't connect via USB even for a 5 minute test? Even better if you can do it with another computer than the one that is normally connecting. Until you can verify that the scanner is still capable of scanning it's hard to troubleshoot any other potential issues Aug 25, 2021 at 14:05
  • 1
    @ToddDabney it seems to be a heisenbug. I connected the USB; got the same error. Tried again with USB after choosing the "remote scanner" option on the printer and it worked. Tried over network (not USB) and it failed; restarted the printer and then it worked over network as well. I swear I restarted it earlier; not sure why it worked this time but it's working now.
    – Wildcard
    Aug 26, 2021 at 7:47

1 Answer 1

1

Can't really help with fixing the problems in Image Capture, but you might be able to scan by alternatively using:

  • System Preferences > Printers & Scanners > (name of scanner) > Scan > Open Scanner

We've had weird problems before with Image Capture and this was the provisional workaround. Image Capture magically worked later on in the future, somehow.

2
  • 1
    Thanks for the suggestion; I tried this but it produced the same error as Image Capture did.
    – Wildcard
    Aug 25, 2021 at 21:03
  • 1
    @Wildcard I know this doesn't help solve the scanner issue, but modern iOS versions (not sure which versions specifically) have a scan feature in the Notes app which produces decently realistic document scans. Can't speak for other mobile operating systems. If you are in a bind and really need documents scanned, it might help you out. Best of luck!
    – leetbacoon
    Aug 27, 2021 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .