0

I recently bought a MacBook Pro M1 and a SanDisk external ssd. The ssd was working very well at first. I could erase, reformat etc. . I tried also other formatting types and there were no problems. But I wanted to partition my ssd. First I partitioned into two Mac OS extended parts. Then, I partitioned it into 3 parts (2 of them Mac OS extended, 1 ExFat). This operation failed. Then it began to fail.

I could not erase the disk. It always showed an error. I erased from a Windows PC then initialized on the Mac and tried again. It worked well once but then, there were problems while reading and writing. Now I cannot erase the disk. Also cannot use it. It always shows the errors shown below. Also first aid shows the errors shown. How can I fix these errors?

Thank you very much.

ERRORS: (Sorry, I could not upload the screenshots due to storage limit)

When I try to write, read data or expand zip files inside the ssd, it shows the error: "Error identifying a writable temporary folder. Try moving the archive to another volume"

When I try to move an app to the ssd, it says: "The operation can't be completed because an unexpected error occurred (error code -50)"

When I try to erase the whole disk, it shows: "The volume on disk4 couldn't be unmounted because it is in use by process 0 (kernel). Couldn't unmount disk. (-69888)"

When I try to eject it, a warning shows up saying that it is in use and asks me whether I want to force eject.

When I try first aid on the whole disk, it says: "Problems were found with the partition map which might prevent booting"

When I try first aid on the volume named 'External SSD'' it says: "Volume could not be unmounted"

When I list the disks on terminal, it shows my ssd.

2
  • Can you add to your question, external ssd plugged, the results of the terminal command : diskutil list external ?
    – Jean_JD
    Jul 19 at 4:15
  • Now, it works fine but during the problem when I listed I could see my ssd as in the following attachment. I think the problem was caused due to the EFI partition. When I plugged in to the Mac, it kept creating this partition. But when I erased the disk it gave an error and when I listed again I couldn't see the type name. The screenshot: discussions.apple.com/content/attachment/… @Jean_JD
    – Kaan
    Jul 20 at 16:45
0

For three days I've been trying many things. But finally I solved it by first restarting the Mac, then formatting my external ssd on a Windows PC to exFAT with aus 128 kb. Then I inserted my ssd to my Mac and used first aid before erasing the ssd. Then I erased it into exFAT format (GUID). Now, it works fine. I tried many things so, I do not know where exactly the problem was but this process fixed it.

-1

First you can try ScanDisk formatting tool from their website

if same issue persist, try replacing the disk if it is under warranty.

because While formatting the disk any disconnection or error can lead to failure of the device.

2
  • 1
    In my experience, vendor disk utilities are terrible and often cause as many problems as they solve.
    – benwiggy
    Jul 19 at 8:54
  • Thank you for your advice. I also checked it but it did not work. Actually I started a quick test on this program but although it has been 20 minutes, it did not even progress 1 %. So I needed to quit.
    – Kaan
    Jul 20 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .