1

I have a MX Keys keyboard, connected via bluetooth, and recently, the media keys just don't work anymore.

If I use something like BeardedSpice, it does, but I don't get why it doesn't work without it as well...

Volume keys work fine though, just the play, next and previous aren't working (on any player).

I don't know what could possibly cause this. Any ideas?

EDIT: best guess is some app is "stealing" the key presses, not sure how to find out if that's true and if so, which app.

EDIT 2: tested in another user and it works. Also did reset SMC et al. My best guess still is that something is stealing the keypresses, no idea what nor how to find out.

EDIT 3: the macbook's physical keyboard also do not work.

EDIT 4: it seem to have stopped working when I briefly migrated from apple music to spotify. Media keys didn't work on spotify, so I assumed it was a spotify issue, and started using bearded spice. Recently I migrated back to apple music and media keys don't work anywhere. I already uninstalled both bearded spice and spotify. I also looked for "leftovers" from those two apps using fd -i bearded and fd -i spotify and didn't find anything. There are also no processes from either running.

EDIT 5: I don't have any media extensions on chrome and already disabled the media key handling by going to chrome://flags/#hardware-media-key-handling.

10
  • hey, try resetting the Bluetooth module clicking on the Bluetooth icon in the Menu Bar holding Shift ⇧ + Option ⌥ — Following your second edit, can you remember what are the newest app that you've installed ? or just before this bug happened. Bluetooth make me go crazy sometimes...
    – tama
    Commented Jul 26, 2021 at 9:21
  • resetting bluetooth was no good as well. Forgot to add it doesn't work on the laptop's physical keyboard as well...
    – caarlos0
    Commented Jul 27, 2021 at 12:12
  • as far as which app... I haven't installed any recently... so, don't know about that either...
    – caarlos0
    Commented Jul 27, 2021 at 12:13
  • actually, I do remember now: it was working, then I changed to spotify for a a time, in which it wasn't working - then I started using bearded spice. But now that I tried to come back to apple music, it doesn't work on apple music either 🤔
    – caarlos0
    Commented Jul 27, 2021 at 12:24
  • 1
    @tama don't have google play music, and most of the time don't have chrome nor its agents running. Anyway, disabled that media key handling, still not working though.
    – caarlos0
    Commented Jul 28, 2021 at 0:54

1 Answer 1

6

I've been having this issue for a few weeks but didn't find a solution. Apple Support was also helpless.

Turns out I am to blame: I've had disabled an internal Apple service but didn't remember... Then enabled it back:

launchctl load -w /System/Library/LaunchAgents/com.apple.rcd.plist

Media keys are now working again. Hope this helps.

3
  • I tried it but I got an error; Load failed: 5: Input/output error Try running `launchctl bootstrap` as root for richer errors.
    – MIT
    Commented Sep 13, 2023 at 18:22
  • Have you tried following the given suggestion? sudo launchctl bootstrap — this will run some Apple stuff as a system admin. I don't know what it will do, but I feel like it's an easy search.
    – emyller
    Commented Sep 20, 2023 at 18:58
  • 1
    Yes, I've tried. it didn't work. But, I fixed it! Whatsapp like apps prevents media keys because of some videos or audio records in inside. So, if media keys stops work, just close those applications.
    – MIT
    Commented Sep 21, 2023 at 17:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .