4

My iMac randomly goes to sleep while I'm using resource-intensive apps such as Unreal Engine or Parallels Desktop.

If I run pmset -g log | grep "Entering Sleep" I get the following log:

2021-07-12 11:17:12 +0200 Sleep                 Entering Sleep state due to 'Low Power Sleep': Using AC (Charge:0%) 21 secs

This is confusing, because my Mac is an iMac (Retina 5K, 27-inch, Late 2014) and of course doesn't have any battery.

I found another similar question with as only answer the suggestion to reinstall macOS, which I did, but I keep having the same problem.

When the iMac is running such resource-intensive apps, the GPU (AMD Radeon R9 M295X 4 GB) reaches 104 degrees celsius, and the CPU stays between 80 and 95. I'm not sure if this can be the reason, but I would expect a different log if the problem was overheating.

What I've tried so far:

  • Reinstall macOS Big Sur
  • Reset PRAM
  • Reset SMC
  • Run Amphetamine to attempt to stop the Mac from going to sleep
  • Run Macs Fan Control to force the fans to go to full speed
  • Made sure I don't have any hot corners associated to "Sleep"
  • Disconnected any external peripheral
  • Vacuumed it to try to remove any dust
  • Ensured there's enough room behind the iMac to let air flow
  • Cleared the iMac from dust with some compressed air (this lowered the CPU temp to ~70 and the GPU to ~90)
  • Installed macOS on an external SSD and ran my apps from it

Nothing helped so far. Could someone help me figure out the issue?

5
  • Did you check the iMac for dust? It tends to accumulate over time and can lead to increased heat inside.
    – nohillside
    Jul 12, 2021 at 9:53
  • @nohillside I hope you mean 'heat'.
    – benwiggy
    Jul 12, 2021 at 10:12
  • @benwiggy so do I :-)
    – nohillside
    Jul 12, 2021 at 10:21
  • 1
    I can't see any dust from the outside, I already tried to vacuum it but nothing came out. I ordered some compressed air cans to try to clean it better though.
    – Fez Vrasta
    Jul 12, 2021 at 10:31
  • 1
    Small update, I bought some compressed air and cleaned the iMac, there was some dust inside and now the temperature seems more normal (~70 for the CPU and ~90 for the GPU) but the iMac still has the same problem :-(
    – Fez Vrasta
    Jul 15, 2021 at 14:48

1 Answer 1

0
+50

Try installing to, booting from, and living on an external drive for a while. I've encountered this same situation and, after extensive debugging, am reasonably sure that it's a result of specifically the built-in storage device overheating. (Though, in my case, I was able to swap out the old storage for new storage. I'm not sure if leaving the old storage in will trigger this issue.)

The sleep-reason routing appears to have been obviously incorrectly implemented for this state, as in both of our cases the system was not battery-powered. It is very misleading.

Additionally, your disk is 7 years old, which under average usage is considered very high risk of failure for consumer-grade storage. It adds to my suspicion that the above is taking place.

4
  • Thanks for the reply, I don't see particularly high temperatures on the hard drive sensors (~50 degrees IIRC), but I tend to agree my poor fusion drive has quite an age at this point. I'll try your suggestion.
    – Fez Vrasta
    Jul 16, 2021 at 6:30
  • I installed macOS on an external SSD, at first I thought that fixed the problem since I managed to use UE for ~2 hours without issues, but just now the problem occurred again, so I suppose we should exclude an HDD issue.
    – Fez Vrasta
    Jul 17, 2021 at 12:02
  • @FezVrasta Were you able to disconnect the internal drive?
    – pion
    Jul 17, 2021 at 17:17
  • No I’m not aware of any way to disconnect it without opening the iMac. But the drive was not in use and the temperature was completely in the safe range
    – Fez Vrasta
    Jul 17, 2021 at 21:21

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .