0

Catalina 10.15.7

I am working on setting up the sharing of my iMac's 'Documents' folder so that I can access my documents there from my MacBook.

Using System Preferences>Sharing, I have added the 'Documents' folder of my user account to the 'Shared Folders' list, but when I do, a new user appears under 'Users' that is named 'Documents', and it has 'Custom' permissions.

I do not understand this behaviour. I don't have a user or a group of users named 'Documents' - the system just made it up.

Can someone please explain why that has happened and tell me if I can delete this "user" that isn't actually a user from the list?

1 Answer 1

0

Short answer: Yes, you can remove the permissions given to Documents, but there is little reason to do so.

Longer answer:

When you share most folders, macOS gives the share these permissions:

  • Your username: R/W
  • Staff group: R
  • Everyone: R

These follow the traditional Unix-style permissions granted to owner, group and world.

But when you share your Documents folder, macOS gives the share these permissions:

  • Your username: R/W
  • Documents group: Custom permissions
  • Everyone: No access

The Documents group (with no members) existed on your Mac before you started sharing, but it was not exposed to view.

There is a similar behaviour when sharing the Desktop and some other folders.

The Documents and similar groups give you an easy way to control sharing on a Mac where you have multiple users. But is likely irrelevant when there is just a single user.

You can change any these permissions as you see fit. But test any changes when connecting from your other Mac.

Strictly speaking, you would (in the Sharing preferences) be changing or removing the permission granted to the Documents group; you would not be deleting the group itself.

You can manage (strongly recommend look but don't change) groups and users by using the Directory Utility /System/Library/CoreServices/Applications/Directory Utility.app.

For a home network with a couple of Macs and one user, I suggest just leaving the default groups and permissions as they are.

One further hint: For connecting from your MacBook it could be easier (and more useful) to share your home folder rather than just Documents folder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .