0

I want to run Windows 10 on my flashed 2009 Mac Pro 5, 1 with Bootcamp.

Currently OS X 10.11.6 and the Nvidia GT 120 are present.

I am able to start the process to create the bootable USB drive but every time the progress bar stops midway and says that there is not enough space on my USB drive. The USB is 123GB and completely cleared. The Windows 10 ISO is around 6GB. I have also tried reformatting it to FAT32 and exFAT, with no luck. I have also disabled Time Machine and automatic backups.

Does anyone know a fix to this or should I just install Windows 10 via DVD?

8
  • 1
    Did the Boot Camp Assistant ask for Windows 10 ISO file and a flash drive without any extra modifications or did you first have to make modifications to the Boot Camp Assistant application? Jul 9 at 4:50
  • This has stopped working since Mojave but should be fine on El Cap. Try the Fight Flash Fraud app F3X (freeware) to test the USB is actually the size it claims to be.
    – Tetsujin
    Jul 9 at 6:11
  • Welcome to Ask Different. I’ve edited out the plenty of searching. If you can document what specifically you searched and how it failed you, we find that gets you the highest quality answers.
    – bmike
    Jul 9 at 15:31
  • @DavidAnderson I did have to edit the info.plist file for it to download Windows 10 and the option to create a bootable USB. Jul 9 at 15:59
  • 1
    @Tetsujin I have installed the program from github and it says I have 120.87 GB of free space on it. Jul 9 at 16:03
0

@Tetsujin Yeah, I think I am just going to go spend $20 on some Dual Layer DVDs and install it like that. Thanks for trying to help though. I just wanted to see if anyone here was struggling with the same issue. Thanks.

1
  • If you have any problems using a DVD, it would be nice if you could update your answer and post them. Jul 9 at 19:22
0

In your question, you asked how to fix using a flash drive. This answer addresses this part of your question.

The following is generally true for Macs of your vintage.

  • Windows needed be installed to BIOS boot. If you can get Windows to UEFI boot, then some of the hardware usually did not work properly.
  • Windows and the Windows installer can not BIOS boot from USB drives.
  • Booting from ExFAT formatted Windows installer first requires installing High Sierra or newer version of MacOS. The High Sierra installer does a firmware upgrade which allows booting from APFS and ExFAT volumes.

So, if the newest version of OS X (or macOS) ever installed is OS X 10.11.6 on your Mac Pro, then one may incorrectly conclude installing Window 10 by USB flash drive would not be possible. However, this is probably not true.

It turns out that the Windows installer (as well as Windows) can be BIOS booted from Grub. One method of acquiring Grub would be to install Debian Linux. This version of Linux offers an USB flash drive installer which can be EFI booted and install a BIOS booting Grub and 64 bit Debian. Once Grub is used to boot the Windows Installer, Grub and Debian can be replaced by Windows. As you can imagine, the installation procedure is complex with many steps. Therefore, you would probably want to try using a DL DVD first to install Windows 10.

Below is a link to an answer where Grub is used to install a 64 bit Windows 10. If you were to choose to use Grub, then the procedure would have to be modified to work with your Mac. For example, you would use a 64 bit Debian instead of a 32 bit Debian.

Can a version of Windows newer than Vista be installed on MacBookPro2,2 2006 Core 2 Duo?

0

Update: I managed to get the installation screens on windows 10. However, the screen says that the product key could not be verified. I have purchased a physical key from Microsoft so I am not worried about it not being authentic. Some error is just happening that prevents the key from being verified.

Even worse, I now cannot boot into my Mac OS because it is not reading my hard drives. It instead shows that black screen that says “no bootable disk”. I tried holding down option and tried doing a PRAM reset with command + option + p + r. No luck. Only the disk reader which has the windows installer is being read and the computer is forced to boot into windows which it can’t install. I manually ejected the installer disk and inserted my installation disk for snow leopard just to see if that would work and it doesn’t detect it.

I have never seen anything like this before. Any ideas?

1
  • You probably should have edited your answer and added this update. Or, asked a new question with a link to this question. This update provides very little additional information. For example, how did you manage to get the installation screen on Windows 10? If you can not boot to macOS, then you must have made changes to the internal drive or the nonvolatile memory (PRAM). What were the changes? So far, you state you booted the Windows 10 installer. That alone should not make any changes. Jul 11 at 16:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .