2

My MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) has been crashing during startup for the last four days. It was running macOS Big Sur. My MacBook froze while I was using it, then suddenly shut down. After re-starting, it froze again shortly and hasn't been able to fully start ever since: it would freeze again during login or right after while re-opening the applications that I had open.

I have tried a few things without success, and I'm not completely sure what to try next.

  • I have run the Apple Diagnostics by holding d while my MacBook starts up, but it found no problem with my system.
  • I have reset the PRAM by holding option + command + P + R while starting my MacBook and waited to hear the boot chime twice, but that didn't fix the problem.
  • I have reset the SMC by holding shift + control + option and the power button, but that didn't fix the problem.
  • I have tried using "safe boot" by holding shift and starting my MacBook. It was showing a red "safe boot" in the upper right corner of the screen, but crashed again during login.
  • I have tried the Internet Recovery by holding command + R while my MacBook starts up, but after downloading the image, my MacBook freezes and shows an Apple logo. The EFI log ends with
    #[SSR|>] Attempting to mount 482075478 bytes as ramdisk
    Booting Recovery OS.
    
  • I have tried re-installing MacOS by creating a bootable installer for macOS, following Apple's instructions, but it crashes after #[EB|LOG:EXITBS:START]: Crash

Finally, my system has proven to be stable when started on a minimal Gentoo Linux distribution. I used it to look at the EFI logs without any issue.

What else can I try to figure out what's wrong with my MacBook? Should I try to completely wipe the internal SSD?

If I remove the EFI partition from the SSD, will I be able to re-install everything? Will I be able to do this using my bootable installer? By putting this Mac in target disk mode and running the installer on another MacBook? Is there any chance that completely wiping the EFI will be of any help?

3
  • (1) When you created the bootable installer, did you use another Mac and put the installer image onto a flash drive? (2) Are you able to boot the failing Mac into Target Disk Mode and mount any of its volumes onto another Mac in order to run Disk First Aid?
    – pion
    Jul 9, 2021 at 9:15
  • Thank you. (1) Yes, I created the bootable installer using another MacBook. (2) Yes, I can boot in Target Disk Mode, but I wasn't able to mount any of its volumes using the USB-C charging cable. It's unclear to me whether this cable can be used for this, as I found diverging information. Is the USB-C cable that came with my Mac supposed to work with Target Disk Mode?
    – Martin
    Jul 9, 2021 at 13:17
  • 1
    No, the USB-C charging cable is not a data cable. You need a Thunderbolt USB-C data cable. Jul 10, 2021 at 22:43

1 Answer 1

0
+100

Providing you have a backup, you should boot with the USB macOS installer flash drive. Run Disk Utility set View -> Show all Devices and First Aid check the internal drive. But not just the drive or even the container. Unmount all volumes inside the container and check each one. Work top down checking each level from Drive -> Container -> Volumes. Also make note if Disk Utility shows any S.M.A.R.T errors on the internal drive which would indicate hardware failure of the SSD (possibly, could still be bad without S.M.A.R.T errors).

If after running First Aid Disk Utility it's still crashing then completely delete the internal drive. Then try re-installing from the USB flash drive. If that fails, try Internet Recovery.

If you use Shift-Option-Command-R during startup, you're offered the macOS that came with your Mac, or the closest version still available. If you use Option-Command-R during startup, in most cases you're offered the latest macOS that is compatible with your Mac. Otherwise you're offered the macOS that came with your Mac, or the closest version still available.

If all else fails, then there is likely a hardware failure that is not being detected by the internal diagnostics. Apple has more advanced diagnostics that the public doesn't have access to.

1
  • Thank you for your interest in my question. I believe my MacBook is done. I eventually wiped the hard drive and started installing Gentoo Linux. It worked for a few hours, but eventually crashed while compiling glibc, never to start again. It's too bad Apple doesn't release the advanced diagnostics tools.
    – Martin
    Jul 16, 2021 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .