0

When I export a movie from Final Cut Pro to compressor, it begins running just fine. However, it will eventually cause my Mac mini (2018) to start getting graphical glitches (parts of the window or dock will flicker in and out) and eventually the computer will lock up, then shut down. I have 32GB of RAM, of which only 16GB are used, so I don't think it's running out of RAM. I've ran Apple Diagnostics numerous times and it doesn't detect it, nor do I have issues with anything else graphically intensive. My CPU doesn't go above 150℉ [65℃], and the GPU doesn't go above 180℉ [82 ℃].

Does anyone know what might be causing this? I'm getting tired of losing progress on projects (apparently final cut doesn't immediately save) as well as the additional time it takes to render something many times before it actually succeeds.

This has started happening while rendering the video (inside Final Cut Pro). Does anyone have any idea what's going on?

5
  • Just curious if, when you say "only 16GB are used," you concluded this by actively monitoring Activity Monitor in real time as the compression process progresses. There can certainly be other causes for the behavior you're seeing but the most obvious that comes to mind is memory starvation and thrashing, so I'd like to rule that out first.
    – pion
    Jul 9 '21 at 9:56
  • @pion yea, I've even seen it happen right after starting the computer, no other applications open.
    – At0mic
    Jul 23 '21 at 18:53
  • Can you confirm that you were actively monitoring Activity Monitor in that case and observing large amounts of free memory?
    – pion
    Jul 23 '21 at 18:55
  • @pion yes, I always have activity monitor open.
    – At0mic
    Jul 23 '21 at 18:58
  • Is this still an issue for you? If so, please give my answer a try so that we can collect actionable data.
    – pion
    Aug 3 '21 at 6:53
-1

Since you've confirmed in comments that it's not due to memory starvation, we should take a global stackshot and see what the CPU is spending cycles on.

  1. Run the following Terminal command to enable kernel symbolication: sudo nvram boot-args="keepsyms=1". Make sure to copy-paste this so that you're entering straight quotes rather than curly/“smart” quotes. (If you get a permission error, you will first need to disable System Integrity Protection. You can re-enable it after you're done with this investigation.)
  2. Reboot your machine and don’t open any apps except for Terminal.
  3. In Terminal, enter the following command, press Return, type in your password, but do not press Return again yet: sudo spindump -reveal -noProcessingWhileSampling
  4. Open FCP and start your compression as normal. Continue until you start experiencing lag.
  5. As soon as you feel lag, go to the Terminal window where you entered your password and press Return so that the command begins to execute. Do not do anything else on the computer while it's running, otherwise you will distort the data collection.
  6. After waiting for >10 seconds to collect a sample and another minute or two to symbolicate and format, you’ll get a file in /tmp/spindump.txt that contains a stackshot of every process.
  7. Upload the file to PasteBin or some equivalent place and add the link to it to your original question.
2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .