Trying to install macOS big sur into a MacBook pro 2019. The "internet recovery" fails with "-1008F" every single time. I've tried it with Wi-Fi and ethernet. I used another Mac to create a bootable USB as described here. The creation process works fine with no problems. I use the option key while turning on and select the USB drive, but it takes me to "internet recovery" regardless, which fails with 1008F. Using command+R also takes me to the "internet recovery" menu. I've run the diagnostic checks by pressing D while turning on, it said everything is fine. There is no problem with the hardware, it was working fine before someone tried to erase the drives. How do I fix this? Found a couple people asking the same on Apple forums (like here) but couldn't see a solution.

  • You created a bootable USB of what version of macOS? Jul 4, 2021 at 14:03
  • @DavidAnderson macOS big sur. That's also what OS macbook had before. Jul 4, 2021 at 14:04
  • Just in case it's helpful for anyone else in this situation, I had a frustrating day trying to figure out what a -2002f error means when attempting an Internet Recovery. I had erased my MBP SSD without realising I couldn't boot from an external drive so machine would go straight to Internet Recovery and fail. The issue was with my router DNS config and setting it to use Google DNS servers & fixed the problem. Dec 23, 2021 at 20:46

2 Answers 2


By default, Mac's that have the Apple T2 Security Chip cannot boot from external media.

You need to change settings from macOS Recovery using the Startup Security Utility, once a User has been created in the installed version of macOS.

Also note that you can not boot to Internet Recovery if you do not connect to the Internet, so make sure your Mac cannot connect to the Internet. Unplug the Ethernet cable, temporarily turn off the Wi-Fi Router and then try booting from the USB flash drive after changing the security settings in the Startup Security Utility.

If you currently do not have macOS installed on your MacBook Pro, and you have never changed the default security settings, then you'll need to install from Internet Recovery or take your Mac to an Apple store, or authorized service center.

See also: Mac models with the Apple T2 Security Chip

  • Command+R to get into Startup Security Utility doesn't work. It takes me to the Internet Recovery screen. No macOS is installed right now. Jul 4, 2021 at 15:12
  • Internet Recovery always fails with -1008F or similar code though. I would do that if I could. Jul 4, 2021 at 15:13
  • @Ayxan Haqverdili, then the last part of my answer applies... " or take your Mac to an Apple store, or authorized service center" Jul 4, 2021 at 15:16
  • @AyxanHaqverdili What did you do in the end? Did you have to take it to the Apple store? I'm having the exactly same problem. Unable to use USB boot and the recovery mode. The internet recovery always gave "-1008F".
    – uPhone
    Sep 11, 2022 at 4:35
  • @uPhone yes, Apple store was the only option. Sep 11, 2022 at 8:28

I currently have a machine with the same issue. I think/hope the internet recovery issue is related to the machine still being locked to another apple ID. https://support.apple.com/en-us/HT206989

I've asked the user to remove it from his iCloud and them I'm going to retry, but he's on vacation so you may get to it sooner.

To recap, here is what I have tried:

  • NVRAM & SMC reset
  • Attempt to boot to recovery mode (w/ and w/o shift), it goes straight to internet recovery
  • Attempt to boot big Sur usb. It sees the drive, but then when I click on it goes to internet recovery
  • Attempt to boot catalina usb. Same as big sur.
  • Internet recovery takes a few minutes and then I get error -1008F. This is on 2 different networks, wired and wireless.

Edit: it worked!! Steps to resolve the issue:

  1. Boot into DFU mode and RESTORE the machine. https://mrmacintosh.com/how-to-restore-bridgeos-on-a-t2-mac-how-to-put-a-mac-into-dfu-mode/
  2. Reboot and load internet recovery. For me, needed to be connected to wired ethernet.
  3. Machine will reboot and load a "Activate Mac" screen. Input credentials of old user and machine unlocked and was able to reinstall Big Sur!
  • This worked perfectly! I needed to RESTORE too! Everything worked exactly how you described it! Thanks! I feel this is the only place where -1008F is mentioned :D :D :D
    – thinklinux
    Jan 18 at 0:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .