4

I am switching from a 2018 MBP i7 with a touch bar to a 2020 MBP M1. The older machine is still running macOS Catalina (v10.15.7) whereas the newer one came with macOS Big Sur preinstalled (v11.4). One thing I cannot figure out is how to force the M1 to show the function keys immediately upon pressing the ๐ŸŒ fn key. Check out the different Keyboard system preferences:

2018

2018 MBP on macOS v10.15.7

2020

2020 MBP on macOS v11.4

Video

Click here to see the difference in a video.

This delay is big enough for me to miss the ๐ŸŒ fncontrolF2 or ๐ŸŒ fncontrolF3 shortcuts that focus on the Menu Bar and Dock, respectively. While I realize that I have the option to show nothing but the function keys on the touch bar, I still find the touch bar useful enough to leave it as is. (I've set it up to change to function keys in certain apps like iTerm.)

Does anybody know of a script or a workaround how to bring back the macOS Catalina behavior?

1
  • The difference between the two is the fact that "hold" is plainly stated in the newer one, thus you must hold it for it to show, not just press it. Jul 4 at 21:44
2

The only workaround that I know of is to choose Do Nothing under Press ๐ŸŒ.

This would disable the short-press functionality and it will skip straight to the Press and Hold functionality.

1

To solve the immediate issue at hand, set the "Press ๐ŸŒโ€ฆ" to "Do Nothing:" Preferences ยป Keyboard ยป Keyboard


However, I still wanted to be able to tap ๐ŸŒ fn twice to start dictation. I was able to re-enable that functionality with the help of a third-party app called BetterTouchTool. Here's how:

  1. In Preferences ยป Keyboard ยป Dictation, create a custom shortcut: Preferences ยป Keyboard ยป Dictation (I used ^โŒฅโŒ˜clear, but it doesn't really matter)

  2. In BetterTouchTool, record a new Key Sequence for ๐ŸŒ fn๐ŸŒ fn and assign the Action to "๐Ÿ”ค Send Keyboard Shortcut" to match the shortcut from the previous step: BetterTouchTool Key Sequence

0

This is unique to new Mac models

This difference is due to your hardware having the globe key (see bold):

To show the function keys in the Touch Bar, press and hold the Fn key or the Globe key ๐ŸŒ (depending on your Mac model) on the keyboard.

Older Macs still display the same options on Big Sur.

Why thereโ€™s a delay

The delay is necessary given that this key also functions as a way to switch keyboards (holding vs. pressing).

Potential workarounds

  1. Try to only have 1 keyboard available (hopefully it skips the delay in this case)?
  2. Try something like what was suggested on a related question:

I solved the issue with this program: https://karabiner-elements.pqrs.org/

And imported this: https://ke-complex-modifications.pqrs.org/#fn_plus_numbers_to_function_keys

3
  • Hi @JBallin and thanks for the suggestion. I looked into Karabiner and it seems like they have to the same issue: "Itโ€™s an issue of macOS, and unfortunately, Karabiner-Elements cannot avoid this issue. (Source.)" Besides, Karabiner would essentially change the shortcut to [๐ŸŒ fn][control][2] and if I wanted that, I could have done so myself in Preferences » Keyboard » Shortcuts » Keyboard » โœ… Move focus to the menu bar (screenshot).
    – ilyakam
    Jul 5 at 20:29
  • ๐Ÿ‘ - what about the first suggestion? I donโ€™t have a model I can tinker with.
    – JBallin
    Jul 5 at 20:49
  • I only have one input source -- U.S. English (proof). Sorry for not addressing that suggestion sooner.
    – ilyakam
    Jul 5 at 22:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .