0

I am trying to revive my m1 macbook pro after it started showing exclamation mark icon with restore url.

Now I am trying to revive it using my other intel-based macbook using apple configurator 2 but on step 3 installation, it fails and shows this error.

The System cannot be restored on this device.


The operation couldn’t be completed. (AMRestoreErrorDomain error 26 - Failed to handle message type StatusMsg (fsck failed)) [AMRestoreErrorDomain – 0x1A (26)]

I also tried restore, but the error persists.

Specs and things I tried

  • Intel-based Mac OS version: Big Sur 11.4
  • Apple Configurator 2: Version 2.14
  • IPSW Files Tested: UniversalMac_11.3.1_20E241_Restore.ipsw UniversalMac_11.4_20F71_Restore.ipsw
  • Tried changing cables

Anyone run into this, or have any suggestions on what to do?

6
  • why are you going that very complicated route? Just reinstall macOS from recovery mode: eclecticlight.co/2020/11/28/startup-modes-for-m1-macs
    – X_841
    Jul 1 at 16:16
  • i tried opening the boot options, but boot options are not working for me either. Same exclamation logo appears after it says "Loading boot options" Jul 1 at 19:52
  • If it can't boot into the recovery partition then something is messed up and I am sorry but I can't help you. What you may try is to create a boot pen drive and try booting from there.
    – X_841
    Jul 1 at 20:05
  • Yeah it looks like recovery partition is corrupted. I tried creating pen drive but in order to boot it you need to open boot options, once you do, same error appears. I might need to go to Apple store Jul 2 at 4:39
  • I read your answer like you have a second MacBook. Why can't you create a boot USB there?
    – X_841
    Jul 2 at 8:13
0

I have finally managed to resolve the issue. Apparently, the issue was related to host macOS not the bricked M1 MacBook.

➡️ I created another user account; and tried to restore. One 3rd attempt it worked!

I am not sure what was the problem, but here are the step that led me to success.

  • Updated the macOS Big Sur to the latest version
  • Restarted host mac after clearing cache and temp directories
  • Removed and re-downloaded the latest IPSW file
  • Created another user account for recovery
  • Tried Revive multiple times with no success
  • Tried Restore; success on third attempt

I hope Apple will fix these random issues with configurator as there is very little help whatsoever with configurator, and its really frustrating..!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .