0

Now I am login apple using a new sandbox account, when I am using in app purchase. It still using the old account. I have tried:

  • close the app and reopen it and do in app purchase, but still popup UI using the old sandbox account

  • reinstall the app and do in app purchase, but still using the old sandbox account

  • tried in another ios device(iPhone XR) using the new sandbox account(the app still using the old official app id)

what should I do to switch to the new sandbox account? By the way, I am using iPad, and the software version: 14.6.

2
  • Yes,I have logged out.@fsb
    – Dolphin
    Jul 1, 2021 at 13:42
  • I am using real device. @fsb
    – Dolphin
    Jul 1, 2021 at 14:39

2 Answers 2

1

The app that you are trying to use is "licensed" to the account that purchased it, ie: the old account.

You will have to download that app again under the new account in order to properly use it.

1
  • I already tried reinstall the app(I have login using new sandbox account).@ErniePC12 but it still did not work
    – Dolphin
    Jul 1, 2021 at 13:43
0

Since iOS 12, the sandbox account are seperate management. In the setting-App Store-Sandbox account, you can manage and switch the sandbox account.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .