2

The Samsung T7 Portable SSD has an encrypted volume that only becomes visible to or usable by macOS when the drive is unlocked using the Samsung Portable SSD software. For an unknown reason (possibly after installing the latest macOS 11.4 Big Sur upgrade?), the Samsung software stopped recognizing that the drive was plugged in. Various solutions online have suggestions for older versions of macOS, but none is effective for the latest operating system version (even reinstalling macOS does not help). The drive and Samsung software work perfectly on other machines (other Macbooks, PCs, etc.), so it is a software issue specific to this one Mac machine.

1

The root issue appears to be that none of the suggested solutions actually does a full removal of the Samsung Portable SSD software. Therefore, when you try to reinstall the software, macOS doesn't prompt you to approve the security exception for the software in System Preferences -> Security & Privacy. In turn, the reinstalled software doesn't work / doesn't have the correct permissions to access the SSD.

Here is the sequence of steps I finally came up with that fully removes all traces of the PSSD software and got me back to a working state. YMMV and you might not have to run all these steps.

  1. cd /Users/<your username>/Library/Application\ Support/Portable_SSD/
  2. osascript CleanupT7PlusAll.scpt
  3. sudo rm -rf /private/var/db/KernelExtensionManagement/AuxKC/CurrentAuxKCA/StashedExtensions/17A3D6DA-575D-40F2-B1EC-59FD1CB31623 (I checked what was in each of the StashedExtensions subfolders and found the one that had Samsung Portable SSD stuff)
  4. sudo rm -rf /Library/Application\ Support/PSSD_Installation
  5. sudo rm -rf /Library//StagedExtensions/Library/Extensions/SamsungPortableSSDDriver.kext
  6. Reboot
  7. Install the "normal" Portable SSD software from the Samsung website. Their website also advertises a special version of the software specifically for Big Sur users, but I did not find this was necessary to use.
  8. Approve the security prompt in System Preferences before allowing the Samsung software installer to reboot your computer -- otherwise you will have to repeat this process
  9. Reboot -- afterwards the SSD should be recognized again and all should be well!

Note that there was no reinstalling of the OS, no changing permissions or disabling SEP in Recovery Mode (crsutil, spctl, etc.); I tried those solutions, but I ended up resetting all those back to defaults before running the above steps since they didn't help.

1
  • The method no longer works, most of the rm commands throw a 'not allowed' error on my MacOS 11.6 install. And even going through recovery mode and deleting from there does not solve the issue, when using the latest disk firmware (updated via a Win box) and the latest MacOS drivers (1.7.4). Stupid thing is that the disk worked with the older drivers.
    – HBateau
    Oct 17 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .