1

My MacBook Pro 2017 (which I enabled the boot sound on, very important later) is stuck in a strange boot loop. When I press the power button, you hear the classic Apple sound, but the Apple logo never appears. I then hear, about every two seconds, the second half of the Apple startup sound in a loop. It's just the full "bong", two seconds later the latter half of the "bong," two seconds later the latter half of the "bong," and so on ad infinitum. The backlight remains on the entire time.

I tired resetting NVRAM and SMC, no luck. I ran Internet Diagnostics, and it found no issues. I actually got into Internet Recovery and that loaded fully, and I ran "First Aid" and it found nothing. I then ran Re-install MacOS, which did it's thing, restarted, and then it was the half-bong sound over and over just like before. I tried again, same half-bong after the reboot. I erased the drive entirely with Disk Utility, reformatted, and did Re-install MacOS. Again downloaded, installed, rebooted to half-bong loop. I then created a USB drive with Fedora Linux on it, and held down Option. It appeared in the list (and so did my "Mac OS Installer" drive), but selecting it just repeated the Half-bong over and over.

I'm out of ideas. Any help would be appreciated.

Edit: Further clarification, this is a base model without Touch Bar or T1/T2. Also, I tried installing rEFInd EFI from Recovery from an external USB drive when I had no ideas left. It installed, but when I rebooted, same thing. It's almost like it's lost its ability to load from EFI of any kind. Remember that both SSD boot and USB boot aren't working.

1 Answer 1

1

OK, a little embarrassing but I'll give the answer.

I switch between Windows and Mac frequently (work/home), and when I kept following the instructions for a NVRAM reset, I kept unwittingly pressing Control+Option+P+R instead of Command+Option+P+R. And so I tried resetting NVRAM several times having no idea I wasn't actually resetting it properly.

Once I realized this from a GIF animation on a website (a picture is worth a thousand words), I tried an NVRAM reset again and it fixed my problem.

Also kids - don't try installing Solus Linux on a MacBook Pro 2017. I tired installing it the first time and it corrupted the NVRAM like this. After fixing it with my instructions above, I tried again and it once again corrupted the NVRAM. Unlike many Linux distributions, It won't work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .