5

I recently purchased a Microsoft keyboard with a number pad.

When trying to use the Mac calculator app with the number pad I have an issue where typing a number will clear out previous numbers.

E.g if I wanted to type "100" in the calculator, I would press 1 0 0. However, the result that shows in the calculator is not 100, but just 0, because it was the last number I pressed.

Example:

Animated gif of the Calculator app showing the input of the number '100' where the display is only showing the '0'

Are my mappings incorrect and causing this issue?

Using Key Codes to check what each key on the numpad does:

1 on the numpad, seems to provide two key down events:

Key Down
     Characters: 
     Unicode:    63289 / 0xf739
     Keys:
     Key Code:   71 / 0x47
     Modifiers:  10486016 / 0xa00100

Key Down
     Characters: 1
     Unicode:    49 / 0x31
     Keys:       #1
     Key Code:   83 / 0x53
     Modifiers:  2097408 / 0x200100
10
  • did you check this guide: support.apple.com/guide/mac-help/… ?
    – Ant
    Commented Jun 24, 2021 at 11:07
  • @Ant yes I checked. I don't have a num lock key, I tried pressing shift+delete and it did nothing. I don't have Mouse Keys activated in the a11y settings. Commented Jun 24, 2021 at 11:09
  • Did you use the numpad delete button for shit+delete?
    – Ant
    Commented Jun 24, 2021 at 11:12
  • 1
    BTW, none of this is controlled by SMC or NVRAM [& Mac doesn't have a CMOS]
    – Tetsujin
    Commented Jun 24, 2021 at 11:21
  • 1
    @Tetsujin I have added an example of what I see when pressing "1" in Key Codes. Does this look correct? It seems to suggest that I'm pressing two keys when I press just one. Commented Jun 24, 2021 at 13:45

2 Answers 2

1

The solution from @fat4talk helped me! Great, thank you!

Just go to https://karabiner-elements.pqrs.org/ to download and install Karabiner-Elements as fat4talk proposed. You have to give the software the required rights in newer macOS (you know, System Preferences > Security & Privacy > General to allow the Karabiner module and then at the Privacy tab to give Karabiner input monitoring rights).

Then open Karabiner-Elements, in Devices mark the Microsoft Number Pad active and make the Simple Modification ('keypad_num_lock' to 'vk_none')

As long as Microsoft/Apple doesn't solve the problem this workaround is ok but nasty...

I'm using macOS Monterey on a MacBookPro14 M1 with the Microsoft Bluetooth NumPad and Office Excel for Mac v16.56

0

I suffered the same problem, and this may work. Use Karabiner, choose the number pad device and make a Simple modification item from 'keypad_num_lock' to 'vk_none'. This will stop sending key code 71 when taping.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .