1

I have a frustration when i take screenshots on my mac, with e.g. shift ⇧+command ⌘ +4. If the screenshot is the first to be opend in the Preview app, then it also opens the "Open" file explorer. Which is not required as I don't want to open any files.

enter image description here

I can't find anyway of preventing this from opening.

It does not open after the first screenshot.

Does anybody know how to prevent this default behaviour?

Update:

Step 1. shift+command+4 to take a screenshot

Step 2. select area to capture

Step 3. the screenshot opens in preview, but the "Open" file explorer also opens at the same time

6
  • Sorry, I can't understand what is happening. Can you list the steps? You open the screenshot in Preview (How?) and you automatically get a File Open dialog? But only the "first"? (First time that Preview is opened?) Do no other files cause this behaviour, e.g. other images?
    – benwiggy
    Jun 23 '21 at 8:43
  • Step 1. shift+command+4 to take a screenshot Step 2. select area to capture Step 3. the screenshot opens in preview, but the "Open" file explorer also opens at the same time
    – FuzzyLlama
    Jun 23 '21 at 9:20
  • If the Preview tool does not have any other images opened in it, e.g. I have closed all other windows before taking this screenshot. Then this behaviour happens. Once there is one window open in preview and I take another screenshot, then this does not happen.
    – FuzzyLlama
    Jun 23 '21 at 9:24
  • Normally, taking a screenshot does not open the image in Preview automatically. In older macOS versions, you just get a file on the Desktop. More recently, the image appears in the bottom right of the screen and you can click on it to edit it. Is that what you're doing?
    – benwiggy
    Jun 23 '21 at 9:28
  • @benwiggy cmd+shift+5 brings up the screenshot tool, where you can set the option to open screenshots in Preview (instead of saving them to e.g. the Desktop).
    – Redarm
    Jun 23 '21 at 9:56
1

As mentioned in the Comments, the behaviour to open screenshots in Preview is set using Command Shift 5. Once set, then all screenshots will be handled this way (including using Command Shift 4).

Preview is set to show an open dialog when it is launched or brought to the foreground and no document window exists.

It would seem to be a bug that the screenshot document is not counted.

If you want to stop the open dialog, then you have to do the following:

Open System Preferences > iCloud > iCloud Drive > Options. Uncheck Preview.

(as per this discussion) https://discussions.apple.com/thread/7936364

Otherwise, you might want to consider not opening all screenshots in Preview, but choosing another behaviour for Screenshots.

1
  • You are awesome @benwiggy the system preferences tip was exactly what I was looking for. Hope you have an awesome day <3
    – FuzzyLlama
    Jun 24 '21 at 7:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .