0

Using the "Start_Server" exec file provided in .zip of set up files for MacOS, and after installing Java, BuildTools, & the Spigot jar files, etc., I try to run "Start_Server" exec file from the command line using the file path and it gives me this error:

zsh: exec format error: /Users/[xxxx]/Documents/MinecraftPython/MinecraftToolsMac/Start_Server

[Process completed]

I had to use the terminal to make the "Start_Server" file executable, but when I try to run it I get that. Any ideas what to do are appreciated.

I just want to get my server initiated so I can start coding with Minecraft...

7
  • Can you tell us what the file is? Is it a script or executable? Commented Jun 22, 2021 at 21:40
  • And what kind of Mac are you using, with which version of macOS?
    – nohillside
    Commented Jun 22, 2021 at 22:02
  • Hi, it's a Unix executable file, and I'm on macOS Catalina 10.15.7 Commented Jun 22, 2021 at 22:41
  • Check out this answer stackoverflow.com/questions/64706647
    – Ant
    Commented Jun 23, 2021 at 9:38
  • Thanks, but it doesn't help. I've read around various forums and threads and am only scratching the surface, but never breaking through to figuring anything practical out. It's marked as a MacOS alias file, and I try to run it by getting its exact file path, and I still get the exec format error. Same thing even when I use chmod to set it as executable. Getting this error on MacOS for unix executable files seems to be common, but still not sure what my options are to get past it. Commented Jun 24, 2021 at 20:06

1 Answer 1

3

Apparently that file got garbled when it was zipped up & made available for download (here's the download source). It's supposed to be an alias to the file Start.command in the Server subdirectory, but the metadata that identifies it as an alias wasn't included so the Finder doesn't know what to do with it.

The simplest solution is to just open Server, and double-click on Start.command instead. If you want, you can make a replacement alias in the Finder (select Start.command, then choose File menu > Make Alias or press Command-L), rename the alias to Start_Server, and move it to the outer directory (replacing the broken file).

If you want to get fancy, you can reattach the missing metadata in Terminal:

xattr -wx com.apple.FinderInfo '61 6C 69 73 4D 41 43 53 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00' ~/Documents/MinecraftPython/MinecraftToolsMac/Start_Server

(This attaches the type code "alis" and the creator code "MACS" to the file, which'll identify it as an alias to a file. Aliases to other kinds of objects -- folders, applications, servers, etc -- have different codes.)

If you have a way to send feedback to the author/maintainers, you should let them know to fix it. Creating the zip file with the Finder should include the relevant metadata (although I'd actually recommend using a symlink instead of an alias for this).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .