3

Is there a way to increase the size of everything (text size, tab size in Chrome, icon size, etc.) without reducing the resolution for an external monitor?

For a laptop itself, using large font for the in-built display works great, but reducing the resolution for an external monitor makes everything "foggy".

I'm using a MacBook Pro 16-inch 2019, with macOS Catalina 10.15.7 (19H2).

2
  • You mean like Retina displays or HiDPI? What is the native resolution of your external Monitor? Something like SwitchResX might be able to help. Jun 22, 2021 at 16:55
  • Native is 3440 x 1440. Using it at 2560 x 1080.
    – ppwc
    Jun 22, 2021 at 20:02

2 Answers 2

1

I have the same problem and also looking for a solution. One half-way solution is to go to System Preferences -> Accessibility -> Zoom and Zoom In:

enter image description here

Its not the ideal solution. Apple itself has this much to say on the topic:

Make text bigger on your Mac · Increase the text size of emails in Mail: In Mail, choose Mail > Preferences, click Fonts & Colors, click Select next to “Message font,” then select a font size in the Fonts window. · Increase the text size of messages in Messages: In Messages, choose Messages > Preferences, click General, then move the “Text size” slider to the right. · Increase the text size in other apps: In many apps, you can press Command-Plus (+) or Command-Minus (–) to adjust text size. If that doesn’t work, check the app’s preferences.

1

You need to use a native scaling factor. This is the only way for the text to look sharp after changing the resolution.

If your resolution is 3440px by 1440px, you need to use 1720px by 720.

3440/2=1720 1440/2=720.

If you divide your resolution by a fraction instead of an integer the text will look blurry. This is caused by the way system renders the UI. The exact explanation is above my level of understanding.

If you don't want to change the resolution, you can use Zoom as suggested by @morpheus, use Hover text or change Font Size and Page Zoom in the Appearance section of Google Chrome's preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .