0

I have a first generation iPhone SE. I dropped it into sea water for maybe about 10 seconds yesterday.

It appears to work fine when there is power left in the battery. The issue is the charging. If I put in the cord and then restart it, or put in the cord while it is off and then it turn it on, the phone charges (possibly more slowly, but I'm not sure) basically as normal. But if I put in the cord while the phone is already on, it does not show the charging indicator (or if the cord was on from boot, taking it out stops the charging and putting it back in does not resume it).

What could be the issue? I assume it can't be purely hardware because of the relation to booting. Any suggestions on how to get it to charge without needing to boot it afresh each time?

0

you can try the following things in order to see if anything helps.

  1. Restart the device (Don't plug the charger in until the device has turned back on and has been unlocked)

  2. Go to Settings > Touch (or Face ID) & Passcode. Make sure USB Accessories is turned on.

  3. Hold the power and home button at the same time until the Apple logo appears

  4. Connect the phone to a Mac or PC that has iTunes and have it check for issues

  5. Restore your iPhone from an iCloud backup (If you don't have one, just skip this step since your issue is probably not related to this)

Finally, you can go to Apple's support site and try to get it fixed. I recommend setting up a Genius Bar appointment in your local Apple store. https://support.apple.com/iphone/repair/service

Let me know if anything here helped!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .