I'm running Big Sur and Spotlight will not find certain applications that come bundled with macOS like Calculator, Keychain, or System Preferences. It will find other non built-in apps I have installed like Chrome, Slack, and Steam just fine.

I have tried the following fixes:

  • Unchecking and checking the /Applications folder from search results in the spotlight settings
  • Adding and removing the /Applications folder in the Privacy settings
  • Turning indexing off and on using sudo mdutil -i off / and sudo mdutil -i on /
  • Running sudo mdutil -Ea /
  • The accepted answer from this question. Note that I did not actually reload the plist file as it describes because I got the error Operation not permitted while System Integrity Protection is engaged and I didn't want to disable SIP to get around it (plus most people seemed to think it wasn't necessary).

None of them worked. Now what?

  • 1
    Did you try all the steps in this accepted answer? It looks like you only did one of them.
    – fsb
    Jun 17, 2021 at 16:01
  • Yes, I tried that and it didn't work. When unloading the plist file I got the Operation not permitted while System Integrity Protection is engaged error. I did not disabled SIP in order to get around it because it seemed dangerous and other said it wasn't necessary.
    – d512
    Jun 17, 2021 at 18:23

3 Answers 3


Well, I figured it out. I did some trial and error using the Privacy tab in Spotlight settings and determined that if I add the /System folder to the list (i.e. tell Spotlight to not index it), then I can't access the built in apps via Spotlight.

After looking at the file system it became obvious why that is. All the built in applications are in the /System/Applications folder, whereas all the ones I installed myself are in the /Applications folder (which was not excluded in the Privacy settings).

This started happening after I upgraded to Big Sur so I'm not sure if Apple moved some things around or what, but there you go. Sanity restored.

  • Yes, from Catalina (I think), the system is on a separate read-only volume, and everything else on a 'Data' volume. The OS gives the illusion of the two being one thing. There's no real benefit to excluding any folders on your startup volume. There are reasons to exclude an entire external volume, but that's it. Give yourself 100 points!
    – benwiggy
    Jun 24, 2021 at 16:17
  • How did you fix it, though? I tried adding the /System/Applications folder in the Privacy tab in Spotlight settings, and then removing it, but that didn't help. Nov 22, 2021 at 15:40

The Terminal app, located at /Applications/Utilities, offers a number of commands specific to Spotlight, including mdutil, a utility for managing the Spotlight index function. The mdutil utility manages the metadata stores used by Spotlight and allows you to turn indexing on or off, erase existing metadata storage files, remove local cache indices of network stores, and a few other useful tasks.

You can use the mdutil command to turn off indexing for a specified volume, as shown above for the volume named MacHD. To turn off indexing for a specific volume launch Terminal, and then use the following command:

sudo mdutil -i off /mountPoint

where mountPoint is the path to the volume. For the startup drive, the path would simply be “/” (without the quotes). For other mounted drives on your Mac, the path would likely be /Volumes/volumeName. As an example, if I wanted to turn Spotlight indexing off for my startup drive, the command would be:

sudo mdutil -i off /

If I wanted to turn indexing off for my Time Machine drive, which is named Backup, the command would be:

sudo mdutil -i off /Volumes/Backup

After executing the command by pressing enter or return, you may be asked for your administrator password. Enter the password at the prompt, and then hit enter or return.

  • 1
    Unfortunately OP says they’ve already tried this in their question.
    – grg
    Jun 23, 2021 at 20:09

Note that Spotlight (at least on my Monterey 12.3.1) has a separate 'System Preferences' search result option which was not selected.

With that selected I could use Cmd-Space to get to Bluetooth preferences using only the keyboard so next time my mouse fails to connect it will be easier to get there to give it a nudge.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .