1

I use localhost to develop Wordpress websites locally but since upgrading to BigSur, I cannot get localhost to show my local websites.

My set up is MacBook Pro with Big Sur v11.4. I use MAMP software v6.3 for my local server environment I have tried to open local websites on Safari 14.1.1 and Chrome Version 91.0.4472.101 There's been brief intermittent success in an incognito Chrome Window and in Safari when I first tried to use localhost:8888 but that was only when I was able to use http and not https (when unsuccessful it redirects to https: and fails).

With MAMP running...

When I type 'localhost' in either browser - I get "it works!"

'https://localhost:8888' returns On Chrome: "This site can’t provide a secure connection localhost sent an invalid response. ERR_SSL_PROTOCOL_ERROR"

On Safari: "Safari can't open the page "https://localhost:8888" because Safari can't establish a secure connection to the server localhost"

I try to type in http only but it always redirects to https: in both browsers

When I use an incognito window in Safari - the website displays as expected but

In Chrome incognito - it returns "This site can’t provide a secure connection localhost sent an invalid response. ERR_SSL_PROTOCOL_ERROR"

It seems like it's https: causing a problem but I don't know if that's a correct assumption or how to fix it. Can anyone help to identify the problem and how to fix please as it's really impacting my ability to work.

I have asked Apple for support but as it's not clear where the issue lies they haven't really taken this on as their problem.

4
  • 2
    Hi @Beknowin'Snr - welcome to Stack Overflow. Have you tried curl - to see what's going on? e.g. curl -v -o - https://localhost:8888/ you can then see where it is breaking .. I'm guessing it's either to do with SSL not being enabled, or to do with certificates, but that output might make it clearer.
    – Mr R
    Jun 16, 2021 at 21:00
  • 2
    Sounds like the process listening on port 8888 does not support https. Jun 17, 2021 at 7:26
  • Thank you both for taking the time to respond. I found a solution which seems to work on Chrome (haven't checked Safari as I don't tend to use it for development on my mac). It was literally a case of ticking 'disable cache' under the developers console > network - and things started to work again! I don't know how that setting was changed in the first place! Jun 18, 2021 at 11:48
  • Mr R - tried curl to see whats happening with my fix in place - anything I need to address?: "➜ ~ curl -v -o - localhost:8888 * Trying ::1... * TCP_NODELAY set * Connected to localhost (::1) port 8888 (#0) * ALPN, offering h2 * ALPN, offering http/1.1 * successfully set certificate verify locations: * CAfile: /etc/ssl/cert.pem CApath: none * TLSv1.2 (OUT), TLS handshake, Client hello (1): * error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number * Closing connection 0 curl: (35) error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number" Jun 18, 2021 at 11:55

1 Answer 1

0

I had a similar issue although I never got "It works" when trying to load localhost. Initially I tried restarting apache with sudo apachectl restart which did not return a response. After restarting and reviewing my set up the solution was to simply start apache, not restart it, go figure.

sudo apachectl start

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .