0

Irssi stopped working. It's installed with homebrew, and when I try to run it, it says this:

dyld: Library not loaded: /System/Library/Perl/5.28/darwin-thread-multi-2level/CORE/libperl.dylib

Referenced from: /usr/local/bin/irssi

Reason: image not found

Abort trap: 6

Any ideas how to fix it? I've tried reinstalling and I installed perl too, did nothing.

4
  • Unfortunately Homebrew relies on Apple supplied third party tools, in this case perl . When Apple chnages them (in this case to 5.30 then the app has to chnage as well. So this is a Homebrew issue they need to chagge the formula. (IMHO the better way is to use another package manager, I think all of them would install their own copy of perl in this case)
    – mmmmmm
    Commented Jun 16, 2021 at 18:28
  • @mmmmmm Ah ok, so I have to wait for homebrew to fix it. Any recommendations of other package managers? Thanks mmmmmm.
    – Joe9000
    Commented Jun 16, 2021 at 20:03
  • apple.stackexchange.com/questions/32724/…
    – mmmmmm
    Commented Jun 16, 2021 at 20:05
  • @mmmmm Thank you for this information. I uninstalled irssi via homebrew and reinstalled via MacPorts and my problem is now resolved. Thank you.
    – Joe9000
    Commented Jun 17, 2021 at 16:45

0

You must log in to answer this question.

Browse other questions tagged .