1

Hi I'm trying to install NTFS-3G on macOS BigSur but every time I run brew install ntfs-3g it reports Error: ntfs-3g has been disabled because it requires FUSE!. Obviously I've already installed macFUSE from osxfuse but brew doesn't seem to recognise it.

How can I solve that?

4

The use of FUSE has been deprecated in homebrew: any formulas that use FUSE as a dependency have been disabled.

Your options are:

  • use a different tap to install the FUSE using package (as mentioned in this issue)
  • use a different package manager if another one provides ntfs-3g
  • find a pre-compiled version of ntfs-3g along with dependencies
  • compile ntfs-3g and dependencies yourself
  • buy Paragon NTFSno affiliation
11
  • Ok. I'm trying compiling by myself. Once cloned directly from tuxera's repo I run these commands: ./autogen.sh ./configure with no errors, but when i run make it returns Undefined symbols for architecture x86_64: "_libintl_setlocale", referenced from: _utils_set_locale in utils.o ld: symbol(s) not found for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: *** [ntfsfix] Error 1 make[1]: *** [all-recursive] Error 1 make: *** [all] Error 2 – Matteo Jun 16 at 10:07
  • 2
    Sure. Skip a pizza and buy Paragon NTFS. shop.paragon-software.com/277/… – Marc Wilson Jun 16 at 14:36
  • 1
    @Matteo the issue Homebrew have is that fuse is now not open source – mmmmmm Jun 16 at 15:50
  • 1
    The reason to pay is that it is cheaper than the time you have spent trying to solve this issue, – mmmmmm Jun 16 at 15:51
  • 1
    @Matteo You think "Open Source" == "I don't have to pay for it". It does not. Further, it works so "really well", that you can't install it. – Marc Wilson Jun 16 at 16:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .