Every time I open the App Store on my iPad, after about 30 seconds, a message appears saying that a number of apps "could not be purchased at this time." This problem seems to originate by attempting to download an app or an update, then canceling when it prompts me for my password. Even if I download it successfully at a later time, the notice persists.

How can I stop this notice from appearing?

  • 1
    Are there any items in your "downloads" list (see iTunes iPad app) – Jason Salaz Mar 1 '12 at 22:14
  • @JasonSalaz No, there aren't. – Timothy Mueller-Harder Mar 2 '12 at 4:06
  • I've had the same problem lately, but I don't need to cancel the password dialog to have it pop up. It notified me of songs as well as apps, but some of them seem to have been cleared somehow automatically. (I.e. there used to be 6 items, now there's just 3.) – Lizzan Mar 2 '12 at 7:25
  • I've got the same problem - and it tells me that it can't purchase a free Instagram app, that is already installed. I think that's somehow connected with several iTunes accounts when an app is purchased in two of them. – Pavel Supruniuk Mar 2 '12 at 12:14
  • @PavelSupruniuk That explanation doesn't make sense with my setup. – Timothy Mueller-Harder Apr 3 '12 at 20:43

This thread on Apple Support Communities has an extensive discussion of the problem. People there deserve credit for finding this solution.

It seems to be caused by a problem in the internal SQLite database file that iOS uses to track downloads from and journal interactions with the App Store. The solution is to wipe the file. The file itself isn't really important; for the most part, it's just a local record of past downloads. AFAIK, the only supported thing you can do to clear that database is a full wipe and restore from backup; however, the free tool iExplorer is able to delete it.

In the iExplorer interface:

  1. Open your device, and navigate to Media > Downloads
  2. In the Downloads folder, you’ll find a file called ‘downloads.[some number].sqlitedb’
  3. Delete that file (Optionally: back it up first.)
  4. Reboot your iOS device. (A clean, empty version of the sqlite database will automatically be created.)

Ta-da! You should be free of that problem... unless some future download re-triggers the underlying bug. (Only Apple can fix that.)

For those curious:

I did some poking around in that SQLite database. It seems that there’s a bug somewhere that is resulting in occasional entries in there with a flag indicating they need to be purchased -- but the App Store itself rejects the purchase attempt for reasons such as “you’ve already purchased that app”.

Specifically, a value of 1 in the ‘is_purchase’ field of the ‘download’ table in that sqlitedb file seems to exactly correspond with the name and count of apps that “cannot be purchased” in the super-annoying dialog box.

| improve this answer | |
  • I tried many different things, and this was the only one that worked for me. – Grant Hutchins Aug 4 '12 at 16:42
  • This seemed so much more logical a solution than the many "swing the phone through the air whilst dancing on one foot" theories out there, but unfortunately didn't work for me :( FWIW the download table in my SQLite DB was empty. – mluisbrown Feb 6 '14 at 17:12
  • Well, this was from two years ago, when iOS 5 was current. I'm not surprised if the inner workings have change since then (although it's disappointing to hear that people are still encountering this issue, or one like it.) – Wes Campaigne Mar 1 '14 at 20:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .