7

I installed Google Chrome on my MacBook for local development and testing. When I start it, it will nag about making it the default browser once in every while.

How can I stop it nagging me about that?

2 Answers 2

1

This answer was tested on Windows/Chromium.

Decline the request, quit Chrome, edit the file ~/Library/Application Support/Google/Chrome/Default/Preferences and replace

"default_browser_infobar_last_declined":"xxxxxxxxxxxxxxxxx" with "default_browser_infobar_last_declined":"90000000000000000"

6
  • If this was "tested on Windows/Chromium", how will this work on a Mac? Also, I was unable to find "default_browser_infobar_last_declined" in my Preferences file.
    – agarza
    Commented Jul 25, 2022 at 14:55
  • Worked for me on Chrome / macOS Monterey. The full JSONPath of the property is $.browser.default_browser_infobar_last_declined, just after the clear_data object and before has_seen_welcome_page. Commented Sep 2, 2022 at 23:59
  • No longer works, sadly
    – ticktock
    Commented Sep 16, 2022 at 17:32
  • default_browser_infobar_last_declined does not exist in my file
    – Jonny
    Commented Nov 11, 2022 at 8:44
  • default_browser_infobar_last_declined exists in mine, but modifying it had no impact Commented Jun 4 at 14:05
0

July 2024 Update

  1. Open Google Chrome
  2. Go to chrome://flags
  3. Search for "Default Browser Prompt Refresh"
  4. Set to "Disabled"

Wish these big tech companies would stop being so annoying!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .