0

First of all, I downloaded the iso file to bootcamp and opened the Bootcamp assistant. After the support program was downloaded, the disk went to the partitioning stage but started giving an error.

Error: Disk Partition error (continued Run First Aid)

I tried a few more times, but it didn't work. I also deleted the SSD device through the recovery mode and reinstalled it. Restarting Bootcamp I got the Disk Partition error again. I tried to partition the test disk myself, but got an error again. (error code 49187)

-NVRAM and SMB reset
-Disc First aid
-Root user
-New Admin User
-A few terminal commands
-Re-download the iso file

For about a week, nothing worked for me.

2
  • Which version of Windows? What model/year Mac? If this the original internal drive? Is macOS installed and running on this drive? Jun 14, 2021 at 20:06
  • Please clarify what doubts you have and what do you need help with specifically?
    – sfxedit
    Jun 15, 2021 at 1:22

1 Answer 1

0

After much effort, I found the solution.

  1. I boot the device in recovery mode.
  2. Open terminal and type diskutil. (To get the disc numbers from the list)
  3. diskutil verifyVolume containerdisknumber
    disk util verifyVolume MacintoshHDdiskNumber
  4. diskutil repairVolume containerdisknumber
    diskutil repairVolume MacintoshHDdiskNumber

and I exited the terminal and restarted the computer. When I restarted the bootcamp everything went fine and completed successfully. I hope it helps anyone who has the same problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .