0

I'm getting a WPA security warning even though I already seem to be using WPA2-Personal with AES.

enter image description here

This also shows up under the WiFi settings on the toolbar:

enter image description here

The suggestion from Apple is to use WPA2/WPA3 with AES, but checking my router settings, I'm already doing that:

enter image description here

airport -I says the link-auth is wpa2-psk:

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport -I
     agrCtlRSSI: -63
     agrExtRSSI: 0
    agrCtlNoise: -91
    agrExtNoise: 0
          state: running
        op mode: station 
     lastTxRate: 866
        maxRate: 867
lastAssocStatus: 0
    802.11 auth: open
      link auth: wpa2-psk
          BSSID: ......
           SSID: <name here>
            MCS: 9
        channel: 36,80

Any ideas why I'm receiving this warning? Is there any additional things that I can check to ensure WPA2 is being used?

2

Your wireless access point is offering WPA. Even though you are not using WPA, you will still need to turn off WPA at the access point in order to remove the message.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .