3

I was happily using my mac with Catalina then updated to Big Sur, now I can't login anymore: I write my password, press enter, then screen stays forever as in the picture, tryed waiting for an hour.

enter image description here

Tryed enabling setup assistant, that also gets stuck with spinning wheel after language selection.

I can ssh from another computer to my Macbook Pro but also "sudo" does not work, it hangs the command forever, tryed waiting many minutes. I was just able to enable root user.

Also trying to access via screen share has the same result.

Already run disk check starting with command + R, cleared NVRAM, ecc. ecc. A lot of things, but I'm locked out of my computer

Does anyone know some sort of solution which is not "reinstall from scratch"?

EDIT: In system.log i see this error:

Jun  9 09:24:44 MacBookPro-2 efilogin-helper[514]: objc[514]: Class EFILWLogging is implemented in both /System/Library/PrivateFrameworks/EFILogin.framework/Versions/A/EFILogin (0x7fff81cfc910) and /System/Library/PrivateFrameworks/EFILogin.framework/Versions/A/Resources/EFIResourceBuilder.bundle/Contents/MacOS/EFIResourceBuilder (0x1097ed078). One of the two will be used. Which one is undefined.
8
  • Have you try a Safe Boot (push shift key at boot) ? Else you can do Reset SMC : support.apple.com/en-us/HT201295
    – user415185
    Jun 9, 2021 at 6:39
  • @Jean_JD Yes, tryed both things but didn't work Jun 9, 2021 at 6:55
  • Have you verify is the keyboard is not in qwerty mode after update?
    – user415185
    Jun 9, 2021 at 7:12
  • @Jean_JD yes, problem is not I can't digit password, but password is accepted then I get ethernal wheel spinning Jun 9, 2021 at 7:15
  • 1
    I don't know. You can try reinstall Big Sur from recovery mode. Else you can force the system create a new administrator. For this read this post : apple.stackexchange.com/a/421787/415185
    – user415185
    Jun 9, 2021 at 10:06

1 Answer 1

1

When you say you tried enabling the setup assistant, what specifically did you do?

In the past, booting to single user mode was simple but based on which MacBook you have and details you didn’t provide in the question (firmware status, FileVault status, DEP status, MDM status), you might be making things worse if you’re not following the Apple procedure precisely to recover a lost password on Secure Enclave Macs with always on encryption.

I know the comments say you think the password is correct, but I suspect you’ve gotten the encryption in a disjoint state.

If you are sure the password reset won’t help, try one time to reinstall the OS from recovery then look at data recovery options if you don’t have a backup or erase install if you don’t care to protect any data now on the Mac.

6
  • for setup assistant I mean this: cd /var/db mv -i .applesetupdone .applesetupdone.old and reboot, with these commands at boot the mac shows setup assistant, some suggest it to create a new user Jun 9, 2021 at 11:00
  • For the encryption thing I don't think this is the problem, this is why: I have an older macbook and I'm using it to access via SSH to the one with Big Sur, while in SSH I can see all the files in my user folder. I was also able to enable root access and su to root. I've attached my time machine disk and the commands to do a backup are also working. Seems something went wrong with the Big Sur update. After finishing instead of going to login screen It was rebooting and rebooting forever, it went to login (not working) only after turning off and on the MacBook Jun 9, 2021 at 11:06
  • @AndreaGiovacchini there can be multiple .AppleSetupDone files with snapshots and APFS. If you got the right one then you’re set. Next step is can you make a different new account and turn off automatic sign in at boot?
    – bmike
    Jun 9, 2021 at 11:44
  • no I can't add a new user, setup assistant is stuck on language selection, spinning wheel there too :( Jun 9, 2021 at 12:18
  • 1
    For the encryption I don't have FileVault enabled, checked with this via SSH: fdesetup status says "FileVault is Off." Jun 9, 2021 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .