3

Running mount -uw / in single-user mode comes up with Permission Denied

I did some research and Catalina has the split-volume file system, so I disabled SIP which still came up with permission denied.

Apparently, in Big Sur, the system volume is also signed. I saw this but of course it requires admin.

What do I do??

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – bmike
    Jun 4, 2021 at 9:23

2 Answers 2

6

If you need create a Admin User on Big Sur the following method works fine :

  1. You boot in Recovery Mode. (cmd+r at boot) .

  2. If Filevault is activated, from Disk Utility, you unlock/mount the System Volume giving the password. (right click on the system volume).

  3. You quit disk utility, then on top menu you select Utilities/Terminal

  4. I suppose the System Volume name is "Macintosh HD", the command is :

    rm /Volumes/"Macintosh HD"/var/db/.AppleSetupDone

  5. If no error message you reboot the Mac and then you will be invited to create a new administrator.

3
  • This is great and likely will work. I’ve added some more general advice in a second answer on how to do this “by the book” with Apple support, but I have tried this and often it helps. Depending on MDM, secure token, and the history of the device, firmware and OS this may or may not work. For most home Macs, this is totally the answer.
    – bmike
    Jun 4, 2021 at 9:21
  • Thank you. Seems other instructions did not properly specify the right path to the .AppleSetupDone. Your instructions worked perfectly.
    – MajorHavoc
    Mar 7, 2022 at 17:26
  • Doesn't work for Monterey (12.3) after unsuccessful unrollment from MS Company Portal =( Mar 18, 2022 at 14:30
0

First - get a back up now before you continue (or check you can restore from your existing backup and it is recent on key important data).


The main thing to do is not follow guides that don’t reflect the current hardware and software. I would suspect anything that relies on single user mode with macOS Catalina and newer and go back to basics.

What are you trying to accomplish and what does Apple support say about that topic?

Disk utility and terminal still work from recovery, so those are the tools I would use instead of single user mode for mounting.

Now on to your implied question. When you don’t have an admin account you either need to reset the password on an existing account or your system has failed in several manners.

Here are the Big Sur specific steps for account management and reset options. https://support.apple.com/guide/mac-help/reset-your-mac-login-password-mh35902/mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .