1

My iPhone 12 Max's Personal Hotspot never shows up on the Macbook Pro M1's wifi list, even though it is always turned on. The only way to make it show up, allowing me to connect, is to open the iPhone's settings and click on the Personal Hotspot menu. Once I'm there, then it suddenly shows up on the Macbook Pro wifi list. That behavior happened with every iPhone I purchased on Brazil, but it didn't happen with the iPhone 11 I purchased on Japan.

Why is that happening? How can I force my iPhone to always broadcast its Personal Hotspot, even when I'm not on its settings screen?

2
  • Is Bluetooth enabled on both devices? AFAIK for this functionality this is required (as well as being signed in to the same Apple account on both devices).
    – dunni
    Jun 2, 2021 at 11:06
  • Yes, Bluetooth is always turned on, on both devices. Yet, my iPhone's network only shows up on the Macbook's wifi list when I launch the iPhone's settings. I can wait minutes and it won't show up. As soon as I launch iPhone's settings, it does.
    – MaiaVictor
    Jun 2, 2021 at 11:08

1 Answer 1

1

Because you have it turned on. You have assumed manual control of the hotspot.

It will, however, not sit there beaconing all the time, because that would eat the battery. It will beacon for a time, then stop. When you enter the settings dialog, it begins beaconing again.

So.

Make sure both devices are logged into the same AppleID, make sure Bluetooth is on so they can see each other, and turn the hotspot OFF.

The phone will appear in the menu and you can select it. Note that the icon is different. The Mac will ask the phone to enable the hotspot, and then connect to it.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .